<div dir="ltr">They&#39;re in the Author field. When this author has been included for other articles in the past those letters have been omitted.</div><br><div class="gmail_quote"><div dir="ltr">On Tue, Nov 13, 2018 at 2:04 PM John Salter &lt;<a href="mailto:J.Salter@leeds.ac.uk">J.Salter@leeds.ac.uk</a>&gt; wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">





<div lang="EN-GB" link="blue" vlink="purple">
<div class="m_-3572662292570048358WordSection1">
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d">Are these characters in the filename, or in the author field for the record to which the document is being uploaded?<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d"><u></u> <u></u></span></p>
<p class="MsoNormal"><b><span lang="EN-US" style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif">From:</span></b><span lang="EN-US" style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif"> James Kerwin [mailto:<a href="mailto:jkerwin2101@gmail.com" target="_blank">jkerwin2101@gmail.com</a>]
<br>
<b>Sent:</b> 13 November 2018 13:59<br>
<b>To:</b> John Salter &lt;<a href="mailto:J.Salter@leeds.ac.uk" target="_blank">J.Salter@leeds.ac.uk</a>&gt;<br>
<b>Cc:</b> <a href="mailto:eprints-tech@ecs.soton.ac.uk" target="_blank">eprints-tech@ecs.soton.ac.uk</a><br>
<b>Subject:</b> Re: [EP-tech] Eprints-Elements and the &quot;ę&quot;<u></u><u></u></span></p>
<p class="MsoNormal"><u></u> <u></u></p>
<div>
<div>
<p class="MsoNormal">Hi John,<u></u><u></u></p>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">It was mostly trial and error using the pointers you gave me the first time I had upload trouble (upload a plain text file with a simple filename etc). It let me upload it with me as the author which is when I looked towards the &quot;special&quot;
 characters.<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">I&#39;ve just done another upload on Test straight to EPrints (going around Elements and RT1/Crosswalks) including the author with special characters. It turns out there&#39;s both an &quot;ę&quot; and a &quot;ł&quot; (I thought it was an L, but it has a wiggle through
 the middle). Both letters by themselves cause the error (e.g. remove the ę it still happens, remove the ł it still happens, remove both and it&#39;s fine).<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">The upload straight to EPrints didn&#39;t work. When I clicked next it gave me the error below (not sure how this mailing list handles images). When I exchanged the characters for their more typical counterparts it went on without issue.<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<div>
<div>
<p class="MsoNormal"><img width="562" height="110" id="m_-3572662292570048358_x0000_i1025" src="cid:image001.png@01D47B59.C22816E0" alt="image.png"><u></u><u></u></p>
</div>
</div>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">I&#39;m not an expert, but I suspect now that this may be more a server issue than specifically EPrints as I would expect EPrints to refuse to save it or give me an EPrints-style warning.<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><u></u> <u></u></p>
</div>
<div>
<p class="MsoNormal">Thanks,<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">James<u></u><u></u></p>
</div>
</div>
</div>
<p class="MsoNormal"><u></u> <u></u></p>
<div>
<div>
<p class="MsoNormal">On Tue, Nov 13, 2018 at 12:55 PM John Salter &lt;<a href="mailto:J.Salter@leeds.ac.uk" target="_blank">J.Salter@leeds.ac.uk</a>&gt; wrote:<u></u><u></u></p>
</div>
<blockquote style="border:none;border-left:solid #cccccc 1.0pt;padding:0cm 0cm 0cm 6.0pt;margin-left:4.8pt;margin-right:0cm">
<div>
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d">Hi James,</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d">If you add a record directly to EPrints, and use the character ę in a name (or other field), does it
 save OK?</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d">I&#39;ve just tried on a 3.3.10 install, and it seems to handle this without any issues - which might point
 to the issue being elsewhere.</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d"> </span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d">Is there anything in the error logs regarding this - or was it a trial-and-error approach to find the
 cause of the problems?</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d"> </span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d">Cheers,</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d">John</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d"> </span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1f497d"> </span><u></u><u></u></p>
<p class="MsoNormal"><b><span lang="EN-US" style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif">From:</span></b><span lang="EN-US" style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif">
<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk" target="_blank">eprints-tech-bounces@ecs.soton.ac.uk</a> [mailto:<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk" target="_blank">eprints-tech-bounces@ecs.soton.ac.uk</a>]
<b>On Behalf Of </b>James Kerwin via Eprints-tech<br>
<b>Sent:</b> 13 November 2018 12:16<br>
<b>To:</b> <a href="mailto:eprints-tech@ecs.soton.ac.uk" target="_blank">eprints-tech@ecs.soton.ac.uk</a><br>
<b>Subject:</b> [EP-tech] Eprints-Elements and the &quot;ę&quot;</span><u></u><u></u></p>
<p class="MsoNormal"> <u></u><u></u></p>
<div>
<div>
<p class="MsoNormal">Hi all,<u></u><u></u></p>
<div>
<p class="MsoNormal"> <u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">We have Elements and EPrints. Recently an article couldn&#39;t be uploaded to EPrints from Elements. After a fair bit of messing around, I&#39;ve worked out the letter &quot;<i><span style="font-size:10.5pt;font-family:&quot;Arial&quot;,sans-serif">ę&quot;
</span></i><span style="font-size:10.5pt;font-family:&quot;Arial&quot;,sans-serif">is preventing the file upload (I removed the author with this letter and the file went on without a problem).</span><u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"> <u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:10.5pt;font-family:&quot;Arial&quot;,sans-serif">Unfortunately, this means the problem is with EPrints. Does anybody know of a straight-forward way of getting this
 to work without necessarily changing the spelling of the author&#39;s name?</span><u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"> <u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:10.5pt;font-family:&quot;Arial&quot;,sans-serif">I found this which I think might be my answer, but we&#39;re using 3.3.14 so maybe there is another solution?</span><u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"> <u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:10.5pt;font-family:&quot;Arial&quot;,sans-serif"><a href="https://emea01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwiki.eprints.org%2Fw%2FFix_for_better_UTF8_support&amp;data=01%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7Ca780a80f31fc413f8c9c08d6497298a6%7C4a5378f929f44d3ebe89669d03ada9d8%7C1&amp;sdata=7ym8r22ckFwl%2BCOPisLckLNJsEMJ0FfAs%2FHSkicYOVA%3D&amp;reserved=0" originalSrc="https://wiki.eprints.org/w/Fix_for_better_UTF8_support" shash="Oz2augY5JBFcHaCO6PDXVoomEuat5YvNxaiRprZd8Rw4sXOUKORPuI7o50qvbLBuatuxH1dTN7owfUnMbLfjoSPSNvqsDCi1xNvBcKqfQKT2veRVLJY/6aOEsWnB4kbECHjzaN9wOYECy7SJIfPSEghXI6J/3q/ZKqh9jTPMCvc=" target="_blank">https://wiki.eprints.org/w/Fix_for_better_UTF8_support</a></span><u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"> <u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:10.5pt;font-family:&quot;Arial&quot;,sans-serif">All advice and guidance greatly appreciated as ever!</span><u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"> <u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:10.5pt;font-family:&quot;Arial&quot;,sans-serif">Thanks,</span><u></u><u></u></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:10.5pt;font-family:&quot;Arial&quot;,sans-serif">James</span><u></u><u></u></p>
</div>
</div>
</div>
</div>
</div>
</blockquote>
</div>
</div>
</div>

</blockquote></div>