<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns:mv="http://macVmlSchemaUri" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="Title" content="">
<meta name="Keywords" content="">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<!--[if !mso]><style>v\:* {behavior:url(#default#VML);}
o\:* {behavior:url(#default#VML);}
w\:* {behavior:url(#default#VML);}
.shape {behavior:url(#default#VML);}
</style><![endif]--><style><!--
/* Font Definitions */
@font-face
        {font-family:Arial;
        panose-1:2 11 6 4 2 2 2 2 2 4;}
@font-face
        {font-family:"Courier New";
        panose-1:2 7 3 9 2 2 5 2 4 4;}
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman",serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p
        {mso-style-priority:99;
        mso-margin-top-alt:auto;
        margin-right:0cm;
        mso-margin-bottom-alt:auto;
        margin-left:0cm;
        font-size:12.0pt;
        font-family:"Times New Roman",serif;}
p.xxmsonormal, li.xxmsonormal, div.xxmsonormal
        {mso-style-name:x_x_msonormal;
        mso-style-priority:99;
        margin:0cm;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Calibri",sans-serif;}
p.xxmsochpdefault, li.xxmsochpdefault, div.xxmsochpdefault
        {mso-style-name:x_x_msochpdefault;
        mso-style-priority:99;
        mso-margin-top-alt:auto;
        margin-right:0cm;
        mso-margin-bottom-alt:auto;
        margin-left:0cm;
        font-size:12.0pt;
        font-family:"Calibri",sans-serif;}
span.xxemailstyle17
        {mso-style-name:x_x_emailstyle17;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
span.xxmsoins
        {mso-style-name:x_x_msoins;
        color:teal;
        text-decoration:underline;}
span.EmailStyle22
        {mso-style-type:personal;
        font-family:"Calibri",sans-serif;
        color:#1F497D;}
span.EmailStyle23
        {mso-style-type:personal-reply;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
span.msoIns
        {mso-style-type:export-only;
        mso-style-name:"";
        text-decoration:underline;
        color:teal;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
        {page:WordSection1;}
--></style>
</head>
<body bgcolor="white" lang="EN-GB" link="blue" vlink="purple">
<div class="WordSection1">
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">Update on this issue.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">I compared the index.html in /html/en/archive/…. Of a single record, both with one that was generated using
</span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">bin/generate_abstracts</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"> and one using
</span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">bin/epadmin refresh_abstracts</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">I noticed the one using
</span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">generate_abstracts</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"> defined the
</span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">http_root</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"> and
</span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">http_cgiroot</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"> as http, while the
</span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">refresh_abstracts</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"> was https.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">So I figured that
</span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">generate_abstracts</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"> was run locally, so it wasn’t forced through
 https, while </span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">refresh_abstracts</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"> was.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">It had to be something that the
</span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">Screen::EPrint::Box</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"> didn’t like about being generated through
 https.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">Well the issue isn’t with
</span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">Screen::Eprint::Box</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"> per say, it was the implementations of Irstats
 and Altmetrics using this plugin&nbsp; </span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">(lib/plugins/EPrints/Plugin/Screen/Eprint/Box/[Altmetric.pm|Irstats.pm]).</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">Both in their
</span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">can_be_viewed</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"> subs have the line:<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">return 0 if $self-&gt;{session}-&gt;get_secure;<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">So it just simply won’t show the box on a page generated through https.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">I have commented this line out and it’s now showing on pages generated through
</span><span style="font-size:11.0pt;font-family:&quot;Courier New&quot;,serif;mso-fareast-language:EN-US">refresh_abstracts.</span><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">I guess my question now is, what is the importance of this line and what am I breaking by commenting it out? :/
<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">Thanks everyone<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">Monica<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US">University of Tasmania<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><a href="https://eprints.utas.edu.au/">https://eprints.utas.edu.au/</a><o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<div style="border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0cm 0cm 0cm">
<p class="MsoNormal"><b><span style="color:black">From: </span></b><span style="color:black">&lt;eprints-tech-bounces@ecs.soton.ac.uk&gt; on behalf of John Salter &lt;J.Salter@leeds.ac.uk&gt;<br>
<b>Reply-To: </b>Eprints Tech &lt;eprints-tech@ecs.soton.ac.uk&gt;<br>
<b>Date: </b>Thursday, 4 January 2018 at 9:21 pm<br>
<b>To: </b>Eprints Tech &lt;eprints-tech@ecs.soton.ac.uk&gt;<br>
<b>Subject: </b>Re: [EP-tech] Refresh Abstracts removing Boxes from Summary Page<o:p></o:p></span></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:11.0pt"><o:p>&nbsp;</o:p></span></p>
</div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">Maybe try this:</span><o:p></o:p></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">Find an item without the boxes.</span><o:p></o:p></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">Save the html source of the page</span><o:p></o:p></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">Run generate_abstracts to make the boxes reappear.</span><o:p></o:p></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">Save the html source of this.</span><o:p></o:p></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">&nbsp;</span><o:p></o:p></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">Diff the two html sources - what's the difference?</span><o:p></o:p></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">That might point us toward what's going on…</span><o:p></o:p></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">&nbsp;</span><o:p></o:p></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">&nbsp;</span><o:p></o:p></p>
<div>
<div style="border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0cm 0cm 0cm">
<p class="MsoNormal"><b><span lang="EN-US" style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif">From:</span></b><span lang="EN-US" style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif"> eprints-tech-bounces@ecs.soton.ac.uk [mailto:eprints-tech-bounces@ecs.soton.ac.uk]
<b>On Behalf Of </b>Monica Wood<br>
<b>Sent:</b> 04 January 2018 09:30<br>
<b>To:</b> eprints-tech@ecs.soton.ac.uk<br>
<b>Subject:</b> Re: [EP-tech] Refresh Abstracts removing Boxes from Summary Page</span><o:p></o:p></p>
</div>
</div>
<p class="MsoNormal">&nbsp;<o:p></o:p></p>
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">As it renders fine when i run generate_abstracts, but then disappears when you edit a record or refresh abstracts, i wouldn't imagine its the javascript.
</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">I haven't changed the templates either.</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">It use to serve all pages&nbsp; (except pages like login) through both http and https, but any requests to http is now redirected to https.
</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">If you look at our repository you will probably see newly created items with no boxes and older records have the boxes. If i generate_abstracts
 on the new ones then the boxes will appear.</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">I just dont understand what could possibly cause this.</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">Monica</span><o:p></o:p></p>
</div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><br>
<br>
<br>
<o:p></o:p></p>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt">On Thu, Jan 4, 2018 at 8:19 PM +1100, &quot;John Salter&quot; &lt;<a href="mailto:J.Salter@leeds.ac.uk" target="_blank">J.Salter@leeds.ac.uk</a>&gt; wrote:<o:p></o:p></p>
<blockquote style="border:none;border-left:solid #CCCCCC 1.0pt;padding:0cm 0cm 0cm 6.0pt;margin-left:4.8pt;margin-top:5.0pt;margin-right:0cm;margin-bottom:5.0pt">
<div>
<p class="MsoNormal">Hmm, interesting...<br>
I believe both those boxes use Javascript to render data.<br>
Is there something amiss with the javascript (e.g. it's not being served over https)?
<br>
<br>
I think there used to be two version of the js that could be served - one secure, the other not. I don't think this variation is needed in modern versions of EPrints - maybe you are referencing the older version of the js in your template?<br>
<br>
Cheers,<br>
John <o:p></o:p></p>
<div class="MsoNormal" align="center" style="text-align:center">
<hr size="2" width="98%" align="center">
</div>
<div id="divRplyFwdMsg">
<p class="MsoNormal"><b><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:black">From:</span></b><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:black">
<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk">eprints-tech-bounces@ecs.soton.ac.uk</a> &lt;<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk">eprints-tech-bounces@ecs.soton.ac.uk</a>&gt; on behalf of Monica Wood &lt;<a href="mailto:monica.wood@utas.edu.au">monica.wood@utas.edu.au</a>&gt;<br>
<b>Sent:</b> 04 January 2018 08:42:15<br>
<b>To:</b> <a href="mailto:eprints-tech@ecs.soton.ac.uk">eprints-tech@ecs.soton.ac.uk</a><br>
<b>Subject:</b> Re: [EP-tech] Refresh Abstracts removing Boxes from Summary Page</span>
<o:p></o:p></p>
<div>
<p class="MsoNormal">&nbsp;<o:p></o:p></p>
</div>
</div>
<div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">Hi John and Adam.<br>
<br>
<br>
</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">Id already tried restarting the httpd service multiple times and the indexer has been restarted since this problem arose.<br>
<br>
<br>
</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">The whole thing has me very confused as it only appeared recently.<br>
<br>
<br>
</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">We did move to shibboleth auth around the same time and all traffic is now directed through https... not sure if these changes would
 have done anything.&nbsp;<br>
<br>
<br>
</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">Thanks</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Arial&quot;,sans-serif;color:black">Monica</span><o:p></o:p></p>
</div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><br>
<br>
<br>
<o:p></o:p></p>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt">On Thu, Jan 4, 2018 at 6:54 PM +1100, &quot;John Salter&quot; &lt;<a href="mailto:J.Salter@leeds.ac.uk" target="_blank">J.Salter@leeds.ac.uk</a>&gt; wrote:<o:p></o:p></p>
<blockquote style="border:none;border-left:solid #CCCCCC 1.0pt;padding:0cm 0cm 0cm 6.0pt;margin-left:4.8pt;margin-top:5.0pt;margin-right:0cm;margin-bottom:5.0pt">
<div>
<p class="MsoNormal">Hi Monica,<br>
It sounds like you might just need to restart Apache...<br>
When running something from the command-line, the EPrints stack is interpreted from the files on disk.<br>
When you 'expire' the abstracts, they are regenerated on-the-fly by the Apache process, using the EPrints stack Apache interpreted when it was started.<br>
<br>
Hope that makes some sense.<br>
If might also be worth restarting the indexer - as this too has an interpreted stack that could differ from the on-disk version you get from the command-line now!<br>
<br>
Cheers,<br>
John <o:p></o:p></p>
<div class="MsoNormal" align="center" style="text-align:center">
<hr size="2" width="98%" align="center">
</div>
<div id="x_divRplyFwdMsg">
<p class="MsoNormal"><b><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:black">From:</span></b><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:black">
<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk">eprints-tech-bounces@ecs.soton.ac.uk</a> &lt;<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk">eprints-tech-bounces@ecs.soton.ac.uk</a>&gt; on behalf of Monica Wood &lt;<a href="mailto:monica.wood@utas.edu.au">monica.wood@utas.edu.au</a>&gt;<br>
<b>Sent:</b> 04 January 2018 01:15:23<br>
<b>To:</b> Eprints Tech<br>
<b>Subject:</b> [EP-tech] Refresh Abstracts removing Boxes from Summary Page</span>
<o:p></o:p></p>
<div>
<p class="MsoNormal">&nbsp;<o:p></o:p></p>
</div>
</div>
<div>
<div>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">Hi All,</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">&nbsp;</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">I’ve got the most bizarre problem happening.</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">&nbsp;</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">My staff started noticing that when they edited an item that the irstats2 downloads box would disappear from the summary page.</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">I had a look and noticed the altmetics box was also disappearing and when I did a refresh_abstracts using epadmin or the regenerate abstracts button from the admin -&gt;
 systems tools, then every box disappeared from every summary.</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">&nbsp;</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">They reappear if I run the script generate_abstracts from the cmdln, but apart from refresh_abstracts setting a abstracts.timestamp variable to state that a page needs
 to be regenerated on request, I cannot see what these commands are really doing differently.</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">Both should be calling the method $eprint-&gt;generate_static() when the page is generated</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">&nbsp;</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">I could solve this by not putting that data into a Screen::EPrint::Box,&nbsp; but it doesn’t actually solve the issue of why refresh is removing them.</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">&nbsp;</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">Thanks</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">Monica Wood</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">&nbsp;</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">Library Systems</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt">University of Tasmania</span><o:p></o:p></p>
<p class="xxmsonormal" style="background:white"><span lang="EN-AU" style="font-size:11.0pt"><a href="https://eprints.utas.edu.au">https://eprints.utas.edu.au</a>
</span><o:p></o:p></p>
</div>
<p style="line-height:10.0pt;background:white"><span style="font-size:10.0pt;font-family:&quot;Calibri&quot;,sans-serif"><br>
<br>
University of Tasmania Electronic Communications Policy (December, 2014). <br>
This email is confidential, and is for the intended recipient only. Access, disclosure, copying, distribution, or reliance on any of it by anyone outside the intended recipient organisation is prohibited and may be a criminal offence. Please delete if obtained
 in error and email confirmation to the sender. The views expressed in this email are not necessarily the views of the University of Tasmania, unless clearly intended otherwise.
</span><o:p></o:p></p>
</div>
</div>
</blockquote>
</div>
</div>
</div>
</blockquote>
</div>
</div>
</body>
</html>