<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman",serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-reply;
        font-family:"Calibri",sans-serif;
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri",sans-serif;
        mso-fareast-language:EN-US;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-GB" link="blue" vlink="purple">
<div class="WordSection1">
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">Hi,<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">[Hopefully Peter or someone will confirm whether 'secure.xml' is needed any more!]<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">Do you have a template file called 'secure.xml' in your install?<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">How does it compare with the 'default.xml' template?<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">Looking at the code in the bin/generate_apacheconf, the default template might get copied (but not all cases are covered - e.g. templates
 in a theme).<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">The javascript variables that differ between secure_auto.js and auto-3.3.15.js are now dynamically generated in [EPRINTS_ROOT]/lib/cfg.d/template_core.pl<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">So I *<b>think</b>* the secure template isn't needed any more.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">If secure.xml exists, and you remove/rename it, does it all work OK?<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">Cheers,<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US">John<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif;color:#1F497D;mso-fareast-language:EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><b><span lang="EN-US" style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif">From:</span></b><span lang="EN-US" style="font-size:11.0pt;font-family:&quot;Calibri&quot;,sans-serif"> eprints-tech-bounces@ecs.soton.ac.uk [mailto:eprints-tech-bounces@ecs.soton.ac.uk]
<b>On Behalf Of </b>Mitocariu Emilian<br>
<b>Sent:</b> 27 September 2017 15:36<br>
<b>To:</b> eprints-tech@ecs.soton.ac.uk<br>
<b>Subject:</b> Re: [EP-tech] Black overlay covers half of the webpage<o:p></o:p></span></p>
<p class="MsoNormal"><o:p>&nbsp;</o:p></p>
<div>
<p class="MsoNormal">Every index.html file from&nbsp;<span style="font-size:9.5pt">[EPRINTS_ROOT]/archives/[ARCHIVEID]/html/en and other subdirectories contains these two lines:</span><o:p></o:p></p>
<div>
<p class="MsoNormal"><span style="font-size:9.5pt">&lt;script src=&quot;<a href="https://eprints.domain.com/javascript/secure_auto.js">https://eprints.domain.com/javascript/secure_auto.js</a>&quot; type=&quot;text/javascript&quot;&gt;&lt;!-- nope --&gt;&lt;/script&gt;</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:9.5pt">&lt;script type=&quot;text/javascript&quot; src=&quot;/javascript/auto-3.3.15.js&quot;&gt;&lt;!--padder--&gt;&lt;/script&gt;</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:9.5pt">I assume it should contain just one of the lines.</span><o:p></o:p></p>
</div>
<div>
<p class="MsoNormal"><o:p>&nbsp;</o:p></p>
</div>
<div>
<p class="MsoNormal"><span style="font-size:9.5pt">Are these files generated with a template? Or what could make eprints to generate these files containing both those lines?&nbsp;</span><o:p></o:p></p>
</div>
</div>
<div>
<p class="MsoNormal"><o:p>&nbsp;</o:p></p>
<div>
<p class="MsoNormal">On Wed, Sep 27, 2017 at 2:43 PM, Mitocariu Emilian &lt;<a href="mailto:mitocariu.emilian@gmail.com" target="_blank">mitocariu.emilian@gmail.com</a>&gt; wrote:<o:p></o:p></p>
<blockquote style="border:none;border-left:solid #CCCCCC 1.0pt;padding:0cm 0cm 0cm 6.0pt;margin-left:4.8pt;margin-right:0cm">
<div>
<p class="MsoNormal">After a little investigation it seems that two javascript files are loaded: javascript/auto-3.3.15.js and javascript/secure_auto.js. Both contain the line &quot;document.observe('dom:loaded', function () { new Lightbox(); });&quot;.<o:p></o:p></p>
</div>
<div>
<div>
<div>
<p class="MsoNormal"><o:p>&nbsp;</o:p></p>
<div>
<p class="MsoNormal">On Wed, Sep 27, 2017 at 1:05 PM, Peter West &lt;<a href="mailto:pjw@repositoryservices.co.uk" target="_blank">pjw@repositoryservices.co.uk</a>&gt; wrote:<o:p></o:p></p>
<blockquote style="border:none;border-left:solid #CCCCCC 1.0pt;padding:0cm 0cm 0cm 6.0pt;margin-left:4.8pt;margin-right:0cm">
<p class="MsoNormal">Hi John<br>
is this caused by a secure.xml template causing a duplicate call?<br>
<br>
Thanks<br>
Peter<br>
<br>
On 27/09/17 10:38, John Salter wrote:<br>
&gt; OK - there is something else making the duplicated lightbox.<br>
&gt;<br>
&gt; I'm sure this has come up previously on the tech list, but I can't find<br>
&gt; any mention of it now.<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; In the javascript/auto-3.3.15.js file, the following line initiates the<br>
&gt; lightbox:<br>
&gt;<br>
&gt; document.observe('dom:loaded', function () { new Lightbox(); });<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; Either there is another line also adding a 'new Lightbox();', or somehow<br>
&gt; the 'dom:loaded' event is being triggered twice.<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; In the screenshot you have the browser development tools open. Do you<br>
&gt; know how to use this to debug javascript?<br>
&gt;<br>
&gt; If so, you could try and see what is calling the Lightbox code.<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; Cheers,<br>
&gt;<br>
&gt; John<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; *From:*<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk" target="_blank">eprints-tech-bounces@ecs.soton.ac.uk</a><br>
&gt; [mailto:<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk" target="_blank">eprints-tech-bounces@ecs.soton.ac.uk</a>] *On Behalf Of *Mitocariu<br>
&gt; Emilian<br>
&gt; *Sent:* 27 September 2017 09:59<br>
&gt; *To:* <a href="mailto:eprints-tech@ecs.soton.ac.uk" target="_blank">eprints-tech@ecs.soton.ac.uk</a><br>
&gt; *Subject:* Re: [EP-tech] Black overlay covers half of the webpage<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; I have one<br>
&gt; file [EPRINTS_ROOT]/archives/[ARCHIVEID]/cfg/static/javascript/auto/90_local.js,<br>
&gt; but I'm guessing that comes with eprints, plus the file only contains a<br>
&gt; comment with some instructions.<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; On Wed, Sep 27, 2017 at 11:30 AM, John Salter &lt;<a href="mailto:J.Salter@leeds.ac.uk" target="_blank">J.Salter@leeds.ac.uk</a><br>
&gt; &lt;mailto:<a href="mailto:J.Salter@leeds.ac.uk" target="_blank">J.Salter@leeds.ac.uk</a>&gt;&gt; wrote:<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;Hi,<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;I think what you're seeing is part of the 'lightbox' functionality.<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;You can see the repeated<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;&lt;div id=&quot;overlay&quot;…&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;&lt;div id=&quot;lightbox&quot;…&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;&lt;div id=&quot;overlay&quot;…&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;&lt;div id=&quot;lightbox&quot;…&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;in the screenshot you sent.<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;For some reason, the lightbox is being set up twice, but only the<br>
&gt;&nbsp; &nbsp; &nbsp;first overlay (which is the black box) is being hidden.<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;Do you have any custom javascript in<br>
&gt;&nbsp; &nbsp; &nbsp;[EPRINTS_ROOT]/archives/[ARCHIVEID]/cfg/static/javascript/?<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;Cheers,<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;John<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;*From:*<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk" target="_blank">eprints-tech-bounces@ecs.soton.ac.uk</a><br>
&gt;&nbsp; &nbsp; &nbsp;&lt;mailto:<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk" target="_blank">eprints-tech-bounces@ecs.soton.ac.uk</a>&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;[mailto:<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk" target="_blank">eprints-tech-bounces@ecs.soton.ac.uk</a><br>
&gt;&nbsp; &nbsp; &nbsp;&lt;mailto:<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk" target="_blank">eprints-tech-bounces@ecs.soton.ac.uk</a>&gt;] *On Behalf Of<br>
&gt;&nbsp; &nbsp; &nbsp;*Mitocariu Emilian<br>
&gt;&nbsp; &nbsp; &nbsp;*Sent:* 27 September 2017 09:07<br>
&gt;&nbsp; &nbsp; &nbsp;*To:* <a href="mailto:eprints-tech@ecs.soton.ac.uk" target="_blank">eprints-tech@ecs.soton.ac.uk</a> &lt;mailto:<a href="mailto:eprints-tech@ecs.soton.ac.uk" target="_blank">eprints-tech@ecs.soton.ac.uk</a>&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;*Subject:* [EP-tech] Black overlay covers half of the webpage<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;Hi,<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;I'm trying to migrate eprints from a server with ubuntu 10.04.4 and<br>
&gt;&nbsp; &nbsp; &nbsp;eprints 3.3.7 to a new server with ubuntu 16.04.03 and eprints<br>
&gt;&nbsp; &nbsp; &nbsp;3.3.15. I did the migration as described<br>
&gt;&nbsp; &nbsp; &nbsp;here: <a href="https://wiki.eprints.org/w/Moving_a_repository" target="_blank">
https://wiki.eprints.org/w/Moving_a_repository</a>, but i also ran<br>
&gt;&nbsp; &nbsp; &nbsp;this command &quot;./bin/epadmin update myrepo&quot; after &quot;./bin/epadmin<br>
&gt;&nbsp; &nbsp; &nbsp;upgrade myrepo&quot;.<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;I set up a temporary domain to test the migration and when I visited<br>
&gt;&nbsp; &nbsp; &nbsp;the webpage, about half of the page was black. I realised that the<br>
&gt;&nbsp; &nbsp; &nbsp;eprints configuration file (cfg/cfg.d/<a href="http://10_core.pl" target="_blank">10_core.pl</a><br>
&gt;&nbsp; &nbsp; &nbsp;&lt;<a href="http://10_core.pl" target="_blank">http://10_core.pl</a>&gt;) still had the original domain set, not the<o:p></o:p></p>
<div>
<div>
<p class="MsoNormal">&gt;&nbsp; &nbsp; &nbsp;temporary one, so I changed it with &quot;./bin/epadmin<br>
&gt;&nbsp; &nbsp; &nbsp;config_core&lt;archivename&gt;&quot;, generated the new webpages and the black<br>
&gt;&nbsp; &nbsp; &nbsp;overlay disappeared.<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;The server is behind a proxy, so I generated a certificate on the<br>
&gt;&nbsp; &nbsp; &nbsp;proxy and enabled HTTPS. Now the black overlay reappeared and I<br>
&gt;&nbsp; &nbsp; &nbsp;can't get rid of it. I attached a print screen to this email for<br>
&gt;&nbsp; &nbsp; &nbsp;more details.<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;Does anyone know what causes the black overlay to appear and how can<br>
&gt;&nbsp; &nbsp; &nbsp;i get rid of it?<br>
&gt;<br>
&gt;<br>
&gt;&nbsp; &nbsp; &nbsp;*** Options:<br>
&gt;&nbsp; &nbsp; &nbsp;<a href="http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech" target="_blank">http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech</a><br>
&gt;&nbsp; &nbsp; &nbsp;*** Archive: <a href="http://www.eprints.org/tech.php/" target="_blank">http://www.eprints.org/tech.php/</a><br>
&gt;&nbsp; &nbsp; &nbsp;*** EPrints community wiki: <a href="http://wiki.eprints.org/" target="_blank">
http://wiki.eprints.org/</a><br>
&gt;&nbsp; &nbsp; &nbsp;*** EPrints developers Forum: <a href="http://forum.eprints.org/" target="_blank">
http://forum.eprints.org/</a><br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt;<br>
&gt; *** Options: <a href="http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech" target="_blank">
http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech</a><br>
&gt; *** Archive: <a href="http://www.eprints.org/tech.php/" target="_blank">http://www.eprints.org/tech.php/</a><br>
&gt; *** EPrints community wiki: <a href="http://wiki.eprints.org/" target="_blank">
http://wiki.eprints.org/</a><br>
&gt; *** EPrints developers Forum: <a href="http://forum.eprints.org/" target="_blank">
http://forum.eprints.org/</a><br>
&gt;<br>
<br>
*** Options: <a href="http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech" target="_blank">
http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech</a><br>
*** Archive: <a href="http://www.eprints.org/tech.php/" target="_blank">http://www.eprints.org/tech.php/</a><br>
*** EPrints community wiki: <a href="http://wiki.eprints.org/" target="_blank">http://wiki.eprints.org/</a><br>
*** EPrints developers Forum: <a href="http://forum.eprints.org/" target="_blank">
http://forum.eprints.org/</a><o:p></o:p></p>
</div>
</div>
</blockquote>
</div>
<p class="MsoNormal"><o:p>&nbsp;</o:p></p>
</div>
</div>
</div>
</blockquote>
</div>
<p class="MsoNormal"><o:p>&nbsp;</o:p></p>
</div>
</div>
</body>
</html>