<div dir="auto">I also try to migrate from ubuntu 12.04 with eprints 3.3.12 to ubuntu 14.04 with eprints 3.3.15. The error when import is about thesis_name. On eprints 3.3.12 just have thesis_type. But on eprints 3.3.15 there is thesis_name. <div dir="auto">Please help for this problem. </div><div dir="auto"><br></div><div dir="auto">Thank you.</div><div dir="auto"><br></div><div dir="auto">Best regards,</div><div dir="auto">Agung Prasetyo W.</div></div><div class="gmail_extra"><br><div class="gmail_quote">On 3 Apr 2017 14:05, &quot;Mitocariu Emilian&quot; &lt;<a href="mailto:mitocariu.emilian@gmail.com">mitocariu.emilian@gmail.com</a>&gt; wrote:<br type="attribution"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div dir="ltr"><div>Hello,</div><div><br></div>I&#39;m trying to migrate the
 data from an old eprints server (ubuntu 10.04, eprints 3.3.7) to a new 
one (ubuntu 16.04, eprints 3.3.15). Maybe worth mentioning i had some 
problems when trying to install eprints and i used the steps from here <a href="http://www.eprints.org/tech.php/22140/attachment/message.html" target="_blank">http://www.eprints.org/tech.ph<wbr>p/22140/attachment/message.htm<wbr>l</a> to successfully install it.<div><br></div><div>I moved the repository to the new server, but when i use the import script on the XML I exported from the old server, i get this error:<br><br><div>eprints@myserver:~/bin$ ./import library --verbose --migration archive XML library.xml</div><div>\C is deprecated in regex; marked by &lt;-- HERE in m/(\C &lt;-- HERE )/ at /usr/share/eprints3/bin/../per<wbr>l_lib/URI/Escape.pm line 205.</div><div><br></div><div>------------------------------<wbr>------------------------------<wbr>------</div><div>---------------- EPrints System Error ----------------------------</div><div>------------------------------<wbr>------------------------------<wbr>------</div><div>Error in configuration:</div><div>Can&#39;t use an undefined value as an ARRAY reference at /usr/share/eprints3/lib/cfg.d/<a href="http://eprint_search_staff.pl" target="_blank"><wbr>eprint_search_staff.pl</a> line 16.</div><div><br></div><div><br></div><div>------------------------------<wbr>------------------------------<wbr>------</div><div>EPrints System Error inducing stack dump</div><div> at /usr/share/eprints3/bin/../per<wbr>l_lib/EPrints.pm line 147.</div><div><span class="m_7367862931541821340gmail-m_-8348297568998879873gmail-Apple-tab-span" style="white-space:pre-wrap">        </span>EPrints::abort(&quot;EPrints&quot;) called at /usr/share/eprints3/bin/../per<wbr>l_lib/EPrints/Config.pm line 281</div><div><span class="m_7367862931541821340gmail-m_-8348297568998879873gmail-Apple-tab-span" style="white-space:pre-wrap">        </span>EPrints::Config::load_reposito<wbr>ry_config_module(&quot;library&quot;) called at /usr/share/eprints3/bin/../per<wbr>l_lib/EPrints/Repository.pm line 510</div><div><span class="m_7367862931541821340gmail-m_-8348297568998879873gmail-Apple-tab-span" style="white-space:pre-wrap">        </span>EPrints::Repository::load_conf<wbr>ig(EPrints::Repository=HASH(<wbr>0x8d06c0)) called at /usr/share/eprints3/bin/../per<wbr>l_lib/EPrints/Repository.pm line 153</div><div><span class="m_7367862931541821340gmail-m_-8348297568998879873gmail-Apple-tab-span" style="white-space:pre-wrap">        </span>EPrints::Repository::new(&quot;EPri<wbr>nts::Repository&quot;, &quot;library&quot;, &quot;cgi&quot;, 0, &quot;noise&quot;, 2) called at /usr/share/eprints3/bin/../per<wbr>l_lib/EPrints.pm line 555</div><div><span class="m_7367862931541821340gmail-m_-8348297568998879873gmail-Apple-tab-span" style="white-space:pre-wrap">        </span>EPrints::repository(EPrints=HA<wbr>SH(0x8d0498), &quot;library&quot;, &quot;noise&quot;, 2, &quot;cgi&quot;, 0) called at /usr/share/eprints3/bin/../per<wbr>l_lib/EPrints/BackCompatibilit<wbr><a href="http://y.pm">y.pm</a> line 447</div><div><span class="m_7367862931541821340gmail-m_-8348297568998879873gmail-Apple-tab-span" style="white-space:pre-wrap">        </span>EPrints::Session::new(&quot;EPrints<wbr>::Session&quot;, 1, &quot;library&quot;, 2) called at ./import line 208</div></div><div><br></div><div>I also tried the method on your wiki (<a href="https://wiki.eprints.org/w/Moving_a_repository" target="_blank">https://wiki.eprints.org/w/<wbr>Moving_a_repository</a>) with the mysqldump but when i do &quot;./bin/epadmin upgrade library&quot; i get the same error.<br></div><div><br></div><div>If you have any idea what the problem might be i would be very glad.</div><div>Thank you.</div></div></div>
<br>*** Options: <a href="http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech" rel="noreferrer" target="_blank">http://mailman.ecs.soton.ac.<wbr>uk/mailman/listinfo/eprints-<wbr>tech</a><br>
*** Archive: <a href="http://www.eprints.org/tech.php/" rel="noreferrer" target="_blank">http://www.eprints.org/tech.<wbr>php/</a><br>
*** EPrints community wiki: <a href="http://wiki.eprints.org/" rel="noreferrer" target="_blank">http://wiki.eprints.org/</a><br>
*** EPrints developers Forum: <a href="http://forum.eprints.org/" rel="noreferrer" target="_blank">http://forum.eprints.org/</a><br>
<br></blockquote></div></div>