<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=utf-8"><meta name=Generator content="Microsoft Word 14 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
        {font-family:Consolas;
        panose-1:2 11 6 9 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0cm;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";
        color:black;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p
        {mso-style-priority:99;
        mso-margin-top-alt:auto;
        margin-right:0cm;
        mso-margin-bottom-alt:auto;
        margin-left:0cm;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";
        color:black;}
pre
        {mso-style-priority:99;
        mso-style-link:"HTML Preformatted Char";
        margin:0cm;
        margin-bottom:.0001pt;
        font-size:10.0pt;
        font-family:"Courier New";
        color:black;}
p.MsoAcetate, li.MsoAcetate, div.MsoAcetate
        {mso-style-priority:99;
        mso-style-link:"Balloon Text Char";
        margin:0cm;
        margin-bottom:.0001pt;
        font-size:8.0pt;
        font-family:"Tahoma","sans-serif";
        color:black;}
span.EmailStyle19
        {mso-style-type:personal;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
span.HTMLPreformattedChar
        {mso-style-name:"HTML Preformatted Char";
        mso-style-priority:99;
        mso-style-link:"HTML Preformatted";
        font-family:Consolas;
        color:black;}
span.EmailStyle22
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
span.BalloonTextChar
        {mso-style-name:"Balloon Text Char";
        mso-style-priority:99;
        mso-style-link:"Balloon Text";
        font-family:"Tahoma","sans-serif";
        color:black;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:612.0pt 792.0pt;
        margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body bgcolor=white lang=EN-GB link=blue vlink=purple><div class=WordSection1><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>As the user ‘eprints’ what does the command ‘which python’ give?<o:p></o:p></span></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>I’d try that as a first option – on our RedHat system, it’s /usr/bin/python<o:p></o:p></span></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'><o:p>&nbsp;</o:p></span></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>Check the user/group for the ~/archives/ARCHIVEID/var/opennoffce.log file too – this might have been created as the www-data user?<o:p></o:p></span></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'><o:p>&nbsp;</o:p></span></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>Cheers,<o:p></o:p></span></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>John<o:p></o:p></span></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'><o:p>&nbsp;</o:p></span></p><div><div style='border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0cm 0cm 0cm'><p class=MsoNormal><b><span lang=EN-US style='font-size:10.0pt;font-family:"Tahoma","sans-serif";color:windowtext'>From:</span></b><span lang=EN-US style='font-size:10.0pt;font-family:"Tahoma","sans-serif";color:windowtext'> eprints-tech-bounces@ecs.soton.ac.uk [mailto:eprints-tech-bounces@ecs.soton.ac.uk] <b>On Behalf Of </b>Jacob Wenzel<br><b>Sent:</b> 19 May 2014 11:40<br><b>To:</b> eprints-tech@ecs.soton.ac.uk<br><b>Subject:</b> [EP-tech] Re: OpenOffice failed to start<o:p></o:p></span></p></div></div><p class=MsoNormal><o:p>&nbsp;</o:p></p><div><p class=MsoNormal style='margin-bottom:12.0pt'>Thanks a lot for your reply!<br><br>I've actually tried fiddling with several versions of LibreOffice and OpenOffice and finally reverted to OpenOffice from the main lucid repository (i've made sure to purge old installs before trying new ones), because all had the same behaviour.<br><br>I had to change the paths in <span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>~/lib/cfg.d/openoffice.pl</span>, because I initially saw the error &quot;OpenOffice is not installed on your system&quot;.<br><br>I could easily search for soffice.bin and change the path to:<br>/usr/lib/openoffice/program/soffice.bin<br><br>$c-&gt;{executables}-&gt;{openoffice} = '/usr/lib/openoffice/program/soffice.bin';<br><br>However there is no &quot;python&quot; in the same folder, and searching for it gives me several locations, because there is no file extension, so I am not sure which location to choose. <br><br>Am I looking for a file or a folder, and are there any clues, that might point me to the right path?<br><br>Running:<br><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>~/archives/ARCHIVEID/bin/openoffice-local.pl ARCHIVEID start</span><br><br>Gives me &quot;Permission denied&quot;. User and group for <span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>openoffice-local.pl</span> is www-data. I've tried changing the user to eprints, but still &quot;permission denied&quot;.<br><br>The log file is now appended to, but unfortunately it is not very helpful:<br>&quot;...<br>OpenOffice process died, restarting...<br>Starting OpenOffice<br>Tried 10 times to start OpenOffice in the last 15 secs. Something is wrong, leaving now&quot;<br><br>Thanks again for you help. I guess I'll try all the &quot;python&quot; locations just to make sure, but I have no idea what to do about the permission denied error.<o:p></o:p></p><div><p><strong><span style='color:#999999'>Med venlig hilsen/Best regards</span></strong><span style='color:#999999'><o:p></o:p></span></p><p><strong><span style='color:#999999'>JACOB WENZEL</span></strong><b><span style='color:#999999'><br><strong>Projektleder</strong></span></b><span style='color:#999999'><o:p></o:p></span></p><p><strong><span style='color:#999999'>ENERGIAKADEMIET</span></strong><span style='color:#999999'><br>Strandengen 1<br>8305 SAMSØ<br>+45 60 61 15 97<br><a href="mailto:jw@energiakademiet.dk"><span style='color:#999999;text-decoration:none'>jw@energiakademiet.dk</span></a><br><a href="http://energiakademiet.dk"><span style='color:#999999;text-decoration:none'>www.energiakademiet.dk</span></a><o:p></o:p></span></p></div><p class=MsoNormal>On 19-05-2014 11:19, John Salter wrote:<o:p></o:p></p></div><blockquote style='margin-top:5.0pt;margin-bottom:5.0pt'><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>Try running it from the commandline:</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>~/archives/ARCHIVEID/bin/openoffice-local.pl ARCHIVEID start</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>&nbsp;</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>I’d have a look at the following:</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>~/lib/cfg.d/openoffice.pl</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>and check all the paths are OK – it may be that Ubuntu installs them elsewhere. I had to tweak it slightly as we use LibreOffce.</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>&nbsp;</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>I think that by default, the openoffice log is overwritten, not appended to (this may have changed since I last looked at it though). Look in ~/lib/plugins/EPrints/Plugin/OpenOffice.pm, at the ‘new’ sub – you might want to change:</span><o:p></o:p></p><p class=MsoNormal style='text-indent:36.0pt'><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>if( open( $fh, &quot;+&gt;&quot;.$self-&gt;logfile() ) )</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>to</span><o:p></o:p></p><p class=MsoNormal style='text-indent:36.0pt'><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>if( open( $fh, &quot;&gt;&gt;&quot;.$self-&gt;logfile() ) )</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>&nbsp;</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>If you’re using OpenOffice for coversheets, it’s also worth knowing that the indexer (that process’ the events) uses it’s own copy of the EPrints stack – so any changes to the config of a reo require the indexer to be restarted before they are picked up.</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>&nbsp;</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>Cheers,</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>John</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>&nbsp;</span><o:p></o:p></p><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1F497D'>&nbsp;</span><o:p></o:p></p><div><div style='border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0cm 0cm 0cm'><p class=MsoNormal><b><span lang=EN-US style='font-size:10.0pt;font-family:"Tahoma","sans-serif";color:windowtext'>From:</span></b><span lang=EN-US style='font-size:10.0pt;font-family:"Tahoma","sans-serif";color:windowtext'> <a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk">eprints-tech-bounces@ecs.soton.ac.uk</a> [<a href="mailto:eprints-tech-bounces@ecs.soton.ac.uk">mailto:eprints-tech-bounces@ecs.soton.ac.uk</a>] <b>On Behalf Of </b>Jacob Wenzel<br><b>Sent:</b> 19 May 2014 07:23<br><b>To:</b> <a href="mailto:eprints-tech@ecs.soton.ac.uk">eprints-tech@ecs.soton.ac.uk</a><br><b>Subject:</b> [EP-tech] OpenOffice failed to start</span><o:p></o:p></p></div></div><p class=MsoNormal>&nbsp;<o:p></o:p></p><p class=MsoNormal>In EPrints v3.3.12 on Ubuntu Server 10.04.04: Whenever I press &quot;Start OpenOffice&quot;, EPrints displays the message: &quot;OpenOffice started&quot;.<br><br>But when I refresh the page or click somewhere else and go back, a red error message is displayed reading &quot;Failed to start OpenOffice&quot;.<br><br>&quot;Openoffice.log&quot; in &quot;/usr/share/eprints3/var&quot; is completely empty, even though it seems to be edited every time I try to start OpenOffice from EPrints.<br><br>This is driving me nuts, please help me solve this puzzle. Any help would be greatly appreciated. <o:p></o:p></p><div><p class=MsoNormal>-- <o:p></o:p></p><p><strong><span style='color:#999999'>Med venlig hilsen/Best regards</span></strong><o:p></o:p></p><p><strong><span style='color:#999999'>JACOB WENZEL</span></strong><b><span style='color:#999999'><br><strong>Projektleder</strong></span></b><o:p></o:p></p><p><strong><span style='color:#999999'>ENERGIAKADEMIET</span></strong><span style='color:#999999'><br>Strandengen 1<br>8305 SAMSØ<br>+45 60 61 15 97<br><a href="mailto:jw@energiakademiet.dk"><span style='color:#999999;text-decoration:none'>jw@energiakademiet.dk</span></a><br><a href="http://energiakademiet.dk"><span style='color:#999999;text-decoration:none'>www.energiakademiet.dk</span></a></span><o:p></o:p></p></div><p class=MsoNormal><br><br><br><o:p></o:p></p><pre>*** Options: <a href="http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech">http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech</a><o:p></o:p></pre><pre>*** Archive: <a href="http://www.eprints.org/tech.php/">http://www.eprints.org/tech.php/</a><o:p></o:p></pre><pre>*** EPrints community wiki: <a href="http://wiki.eprints.org/">http://wiki.eprints.org/</a><o:p></o:p></pre><pre>*** EPrints developers Forum: <a href="http://forum.eprints.org/">http://forum.eprints.org/</a><o:p></o:p></pre></blockquote><p class=MsoNormal><o:p>&nbsp;</o:p></p></div></body></html>