Did you enable the import from web configuration parameter?<br>Denis<br><br>----- Reply message -----<br>From: &quot;John Salter&quot; &lt;J.Salter@leeds.ac.uk&gt;<br>To: &quot;&#39;eprints-tech@ecs.soton.ac.uk&#39;&quot; &lt;eprints-tech@ecs.soton.ac.uk&gt;<br>Subject: [EP-tech] Re: Importing files from another system<br>Date: Thu, Jun 21, 2012 15:55<br><br><br>Yep - that didn&#39;t work either :o\<br><br>According to this:<br>http://wiki.eprints.org/w/Import_From_URL <br>I was also missing a &lt;files&gt; around the &lt;file&gt;.<br>I&#39;ve added that and re-tried all the options, so far none work :o\<br><br>Any other suggestions?<br><br>Cheers,<br>John<br><br>-----Original Message-----<br>From: eprints-tech-bounces@ecs.soton.ac.uk [mailto:eprints-tech-bounces@ecs.soton.ac.uk] On Behalf Of Jose Martin<br>Sent: 21 June 2012 14:40<br>To: eprints-tech@ecs.soton.ac.uk<br>Subject: [EP-tech] Re: Importing files from another system<br><br>Have you tried for local files<br><br>        &lt;url&gt;file:///path_to_file&lt;/url&gt;<br><br>?<br><br>-----Original Message-----<br>From: eprints-tech-bounces@ecs.soton.ac.uk [mailto:eprints-tech-bounces@ecs.soton.ac.uk] On Behalf Of John Salter<br>Sent: 21 June 2012 14:24<br>To: &#39;eprints-tech@ecs.soton.ac.uk&#39;<br>Subject: [EP-tech] Re: Importing files from another system<br><br>Nothing silly in the verbose output.<br><br>I can wget the file over http (when trying the http method), but even using the file from the local filesystem doesn&#39;t work :o\<br><br><br>-----Original Message-----<br>From: eprints-tech-bounces@ecs.soton.ac.uk [mailto:eprints-tech-bounces@ecs.soton.ac.uk] On Behalf Of Yuri<br>Sent: 21 June 2012 13:48<br>To: eprints-tech@ecs.soton.ac.uk<br>Subject: [EP-tech] Re: Importing files from another system<br><br>run the command with --verbose --verbose and try to see what happen. Can you go to port 80 from the server to another server? Check your firewall settings.<br><br>Il 21/06/2012 14:22, John Salter ha scritto:<br>&gt; Hi,<br>&gt; I&#39;m trying to import files from another system, into EPrints.<br>&gt; I can either copy the files onto the server, or make them available over http.<br>&gt;<br>&gt; In the XML, I&#39;ve tried specifying (in an&lt;eprints&gt;&lt;eprint&gt; &nbsp;node) <br>&gt; &lt;document&gt;<br>&gt;         &lt;file href=&quot;/path/to/my.pdf&quot; /&gt;<br>&gt; &lt;/document&gt;<br>&gt; &nbsp; - or -<br>&gt; &lt;document&gt;<br>&gt;         &lt;file&gt;<br>&gt;                 &lt;url&gt;http://url.of/my.pdf&lt;/url&gt;<br>&gt;         &lt;/file&gt;<br>&gt; &lt;/document&gt;<br>&gt;<br>&gt; And importing with:<br>&gt;&gt; bin/import ARCHIVENAME --enable-file-imports --enable-web-imports <br>&gt;&gt; --user 1 archive XML test.xml<br>&gt; Both import the metadata from the XML OK, but neither option attaches the file to the eprint.<br>&gt;<br>&gt; What am I doing wrong - or will this even work?<br>&gt;<br>&gt; Cheers,<br>&gt; John<br>&gt; *** Options: <br>&gt; http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech<br>&gt; *** Archive: http://www.eprints.org/tech.php/<br>&gt; *** EPrints community wiki: http://wiki.eprints.org/<br><br>*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech<br>*** Archive: http://www.eprints.org/tech.php/<br>*** EPrints community wiki: http://wiki.eprints.org/<br><br>*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech<br>*** Archive: http://www.eprints.org/tech.php/<br>*** EPrints community wiki: http://wiki.eprints.org/<br><br>*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech<br>*** Archive: http://www.eprints.org/tech.php/<br>*** EPrints community wiki: http://wiki.eprints.org/<br><br>*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech<br>*** Archive: http://www.eprints.org/tech.php/<br>*** EPrints community wiki: http://wiki.eprints.org/<br>