[EP-tech] Data Repository Upgrade - Staging area file problems

James Kerwin jkerwin2101 at gmail.com
Thu May 19 17:11:55 BST 2022


CAUTION: This e-mail originated outside the University of Southampton.
Hi All,

I'm still trying to upgrade the version of EPrints on our data repository (using recollect).

I'm having trouble with the staging area. We create the record and don't upload any files, but do give it a title, author etc.

Then when we go and create the folder with a matching EPrints ID in the staging area. Going back to the upload screen we would expect to see the folder/files, but neither is there. It passes the logic in URL.pm so that it knows the directory is there and real, but is unable to read the contents. (E.g. the text starts with "Your data staging area has been set up and includes the files listed below.")

Where the files should be listed there is just ".." I've even changed the "Staging" text to be the value held in $eprintid so I know that it's looking for the correct directory and not something with some preceding zeros to the ID.

Does anybody know what could cause this? We do currently have a new/empty drive mounted to the "documents" folder for the purpose of testing. This drive does not have NFS access which the previous one did. Could that be the issue? I've set the permissions of the folder to be rwx by anyone and everyone on the server (for the purpose of testing and ruling out causes).

Thanks,
James


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20220519/303d1fdf/attachment-0001.html 


More information about the Eprints-tech mailing list