[EP-tech] View and Move Screen Plugins

David R Newman drn at ecs.soton.ac.uk
Thu Apr 1 11:13:00 BST 2021


Hi Yuri,

This is an odd one, as if the "Move to the Repository" button does not 
actually do what it says when the setting is the default, position = 
100, then it seems extremely unlikely that this would not have been 
identified as a bug by now, as this would likely apply to all 
repositories running this version.

It is possible to reconfigure these values in the local archive's 
configuration, (typically plugins.pl).  It is worth checking there to 
see if there is anything that relates to the EPrints::Move screen 
plugin.  It may also be worth checking you archive's phrase files to see 
if the is a "Move to the repository" assigned to another button other 
than the one from EPrints::Move.  Beyond, that all I can suggest is try 
setting the position to 101 rather than 200 to see if this fixes the 
functionality of the button without changing the ordering of buttons.

This sounds like one of the problems I would have difficultly debugging 
even if the code was in front of me.  So I am not overly confident any 
one of my suggestions will fix your problem.  If this problem has only 
just occurred, I would be tempted to run a find command over all your 
archive config and core EPrints codebase files, to see if anything 
relevant has recently been modified.

Regards

David Newman

On 01/04/2021 10:50, Yuri via Eprints-tech wrote:
> *CAUTION:* This e-mail originated outside the University of Southampton.
>
> Context: Eprints 3.3.15
>
> When I view an Eprints (as admin) I get the "Move to the repository", 
> "Return Item (with notification)", "Delete Item (with notification)" 
> buttons on top (eprint_actions_bar_buffer).
>
> The standard config for "Move to the repository" ( 
> perl_lib/EPrints/Plugin/Screen/EPrint/Move.pm ) is
>
> { place => "eprint_actions_bar_buffer", action => "move_archive", 
> position => 100, },
>
> The form render as:
>
> <form method="post" accept-charset="utf-8" action="/cgi/users/home" 
> enctype="multipart/form-data">
>     <input name="screen" id="screen" value="EPrint::View" type="hidden">
>     <input name="eprintid" id="eprintid" value="263" type="hidden">
>     <input class="ep_form_action_button" value="Move to Repository" 
> name="_action_move_archive" type="submit">
> </form>
>
> As you can see, the form points to EPrint::View instead of EPrint::Move.
>
> If I change the config to:
>
> { place => "eprint_actions_bar_buffer", action => "move_archive", 
> position => 200, },
>
> It displays correctly EPrint::Move but "Return Item (with 
> notification)" move to the first position and have the same issue, it 
> renders with EPrint::View instead of EPrint::Move.
>
> So the first button always get EPrint::View, the others EPrint::Move. 
> Obviously the one with EPrint::View fails with "This screen 
> (EPrint::View) does not know how to process this action: move_archive".
>
> Any idea on how to solve this?
>
> P.S: This is the full config for Move.pm (the standard one):
>
>     $self->{actions} = [qw/ move_inbox move_buffer move_archive 
> move_deletion /];
>
>     $self->{appears} = [
> { place => "eprint_actions",     action => "move_inbox",     position 
> => 600, },
> { place => "eprint_editor_actions",     action => "move_archive",    
>  position => 400, },
> { place => "eprint_editor_actions",     action => "move_buffer",    
>  position => 500, },
> { place => "eprint_editor_actions",     action => "move_deletion",    
>  position => 700, },
> { place => "eprint_actions_bar_buffer", action => "move_archive", 
> position => 100, },
> { place => "eprint_actions_bar_archive", action => "move_buffer", 
> position => 100, },
> { place => "eprint_actions_bar_archive", action => "move_deletion", 
> position => 100, },
> { place => "eprint_actions_bar_deletion", action => "move_archive", 
> position => 100, },
> { place => "eprint_review_actions", action => "move_archive", postion 
> => 200, }, # I've already correct postion -> position in the instance
>     ];
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: https://eur03.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.eprints.org%2Ftech.php%2F&amp;data=04%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7C89ca5b294a864980c4f808d8f4f6bb1a%7C4a5378f929f44d3ebe89669d03ada9d8%7C0%7C0%7C637528687903783634%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=SxZAT4J%2BjXH2SnRfqm4qwqVY5e5gbC0uOf%2BMxmbbAvk%3D&amp;reserved=0
> *** EPrints community wiki: https://eur03.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwiki.eprints.org%2F&amp;data=04%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7C89ca5b294a864980c4f808d8f4f6bb1a%7C4a5378f929f44d3ebe89669d03ada9d8%7C0%7C0%7C637528687903783634%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=fd%2BbuzuvY3jS%2FEfwuJI1YJvrE1LeRQ5aUypWxoL0q6A%3D&amp;reserved=0


-- 
This email has been checked for viruses by AVG.
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.avg.com%2F&amp;data=04%7C01%7Ceprints-tech%40ecs.soton.ac.uk%7C89ca5b294a864980c4f808d8f4f6bb1a%7C4a5378f929f44d3ebe89669d03ada9d8%7C0%7C0%7C637528687903783634%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=Mpp1wEZX3pyGC5Sjm2qMv2jwn5GEQEqpzJLdL7dOjo4%3D&amp;reserved=0
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20210401/76bf9bd8/attachment-0001.html 


More information about the Eprints-tech mailing list