[EP-tech] Black overlay covers half of the webpage

Mitocariu Emilian mitocariu.emilian at gmail.com
Wed Sep 27 12:43:37 BST 2017


After a little investigation it seems that two javascript files are loaded:
javascript/auto-3.3.15.js and javascript/secure_auto.js. Both contain the
line "document.observe('dom:loaded', function () { new Lightbox(); });".

On Wed, Sep 27, 2017 at 1:05 PM, Peter West <pjw at repositoryservices.co.uk>
wrote:

> Hi John
> is this caused by a secure.xml template causing a duplicate call?
>
> Thanks
> Peter
>
> On 27/09/17 10:38, John Salter wrote:
> > OK - there is something else making the duplicated lightbox.
> >
> > I'm sure this has come up previously on the tech list, but I can't find
> > any mention of it now.
> >
> >
> >
> > In the javascript/auto-3.3.15.js file, the following line initiates the
> > lightbox:
> >
> > document.observe('dom:loaded', function () { new Lightbox(); });
> >
> >
> >
> > Either there is another line also adding a 'new Lightbox();', or somehow
> > the 'dom:loaded' event is being triggered twice.
> >
> >
> >
> > In the screenshot you have the browser development tools open. Do you
> > know how to use this to debug javascript?
> >
> > If so, you could try and see what is calling the Lightbox code.
> >
> >
> >
> > Cheers,
> >
> > John
> >
> >
> >
> > *From:*eprints-tech-bounces at ecs.soton.ac.uk
> > [mailto:eprints-tech-bounces at ecs.soton.ac.uk] *On Behalf Of *Mitocariu
> > Emilian
> > *Sent:* 27 September 2017 09:59
> > *To:* eprints-tech at ecs.soton.ac.uk
> > *Subject:* Re: [EP-tech] Black overlay covers half of the webpage
> >
> >
> >
> > I have one
> > file [EPRINTS_ROOT]/archives/[ARCHIVEID]/cfg/static/
> javascript/auto/90_local.js,
> > but I'm guessing that comes with eprints, plus the file only contains a
> > comment with some instructions.
> >
> >
> >
> > On Wed, Sep 27, 2017 at 11:30 AM, John Salter <J.Salter at leeds.ac.uk
> > <mailto:J.Salter at leeds.ac.uk>> wrote:
> >
> >     Hi,
> >
> >     I think what you're seeing is part of the 'lightbox' functionality.
> >
> >     You can see the repeated
> >
> >     <div id="overlay"…>
> >
> >     <div id="lightbox"…>
> >
> >     <div id="overlay"…>
> >
> >     <div id="lightbox"…>
> >
> >     in the screenshot you sent.
> >
> >     For some reason, the lightbox is being set up twice, but only the
> >     first overlay (which is the black box) is being hidden.
> >
> >
> >
> >     Do you have any custom javascript in
> >     [EPRINTS_ROOT]/archives/[ARCHIVEID]/cfg/static/javascript/?
> >
> >
> >
> >     Cheers,
> >
> >     John
> >
> >
> >
> >     *From:*eprints-tech-bounces at ecs.soton.ac.uk
> >     <mailto:eprints-tech-bounces at ecs.soton.ac.uk>
> >     [mailto:eprints-tech-bounces at ecs.soton.ac.uk
> >     <mailto:eprints-tech-bounces at ecs.soton.ac.uk>] *On Behalf Of
> >     *Mitocariu Emilian
> >     *Sent:* 27 September 2017 09:07
> >     *To:* eprints-tech at ecs.soton.ac.uk <mailto:eprints-tech at ecs.
> soton.ac.uk>
> >     *Subject:* [EP-tech] Black overlay covers half of the webpage
> >
> >
> >
> >     Hi,
> >
> >
> >
> >     I'm trying to migrate eprints from a server with ubuntu 10.04.4 and
> >     eprints 3.3.7 to a new server with ubuntu 16.04.03 and eprints
> >     3.3.15. I did the migration as described
> >     here: https://wiki.eprints.org/w/Moving_a_repository, but i also ran
> >     this command "./bin/epadmin update myrepo" after "./bin/epadmin
> >     upgrade myrepo".
> >
> >
> >
> >     I set up a temporary domain to test the migration and when I visited
> >     the webpage, about half of the page was black. I realised that the
> >     eprints configuration file (cfg/cfg.d/10_core.pl
> >     <http://10_core.pl>) still had the original domain set, not the
> >     temporary one, so I changed it with "./bin/epadmin
> >     config_core<archivename>", generated the new webpages and the black
> >     overlay disappeared.
> >
> >
> >
> >     The server is behind a proxy, so I generated a certificate on the
> >     proxy and enabled HTTPS. Now the black overlay reappeared and I
> >     can't get rid of it. I attached a print screen to this email for
> >     more details.
> >
> >
> >
> >     Does anyone know what causes the black overlay to appear and how can
> >     i get rid of it?
> >
> >
> >     *** Options:
> >     http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >     *** Archive: http://www.eprints.org/tech.php/
> >     *** EPrints community wiki: http://wiki.eprints.org/
> >     *** EPrints developers Forum: http://forum.eprints.org/
> >
> >
> >
> >
> >
> > *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-
> tech
> > *** Archive: http://www.eprints.org/tech.php/
> > *** EPrints community wiki: http://wiki.eprints.org/
> > *** EPrints developers Forum: http://forum.eprints.org/
> >
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
> *** EPrints developers Forum: http://forum.eprints.org/
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20170927/e42b70c1/attachment.html 


More information about the Eprints-tech mailing list