[EP-tech] DataCite Doi Plugin

Tomasz Neugebauer Tomasz.Neugebauer at concordia.ca
Tue Jun 13 21:43:55 BST 2017


I hope that Alfredo received some help from back in April, I didn’t see it on the list.
I found installing the DataCite plugin difficult as well. I got it work eventually, but it was not trivial.
I think that the Bazaar plugin is probably out of synch with all the fixes that were applied in the last year or so to the github code.
Here is a couple of points to remember when troubleshooting DataCite plugin (something I was doing today):


1)      The indexer does much of the work, so if you make a change to the DataCite Event script, you have to restart the indexer before you see a change.  Today, I had to make a change to accommodate this issue: https://github.com/eprintsug/DataCiteDoi/issues/13 for example, since I was minting a DOI for an item with a title in French.

2)      The error/logging for minting seems mostly to be stored with the indexer.log in var folder.

Thanks to David for flagging issue 13!  I spent half the day trying to figure this one out before I found the issue post.

Tomasz


From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Alfredo Cosco
Sent: April-10-17 3:33 AM
To: eprints-tech at ecs.soton.ac.uk
Subject: [EP-tech] DataCite Doi Plugin

Hi all,
i'm trying to configure DataCite Doi plugin found on eprintsug github page:

https://github.com/eprintsug/DataCiteDoi

The plugin seems correctly installed, the button to coin a DOI appears but seems that it doesn't work.

I  set the plugin with the test API address:

https://mds.test.datacite.org

I set it with my datacite user and pw.

But new DOIs do not appear in the list of generated DOI.

Please help me.

Thanks,
Alfredo


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20170613/242b6da7/attachment.html 


More information about the Eprints-tech mailing list