[EP-tech] Installing ePrints 3.3.15 on CentOS7 error

Mathieu Perron Mathieu_Perron at uqac.ca
Thu Apr 13 21:20:44 BST 2017


Hello World,

I'm trying to setup a new server for our ePrints repository (the current repository is running on obsolete CentOS5).  I installed all dependencies as stated in the wiki but when I run "yum install eprints" I get the following error:

Error: Package: eprints-3.3.15-1.el6.noarch (rpm-eprints-org)
           Requires: perl(Apache::DBI)

I've googled the package perl-apache-dbi and it was available via the EPEL repository but has been removed because it wasn't maintained.  I tried running  "yum install eprints -skip-broken" but there's a bunch of stuff not installed because there are missing dependencies.

Is there a better way to install ePrints via YUM?  Is there a tutorial somewhere with all I need to install to make ePrints work on CentOS7?

Thank you for your kindness and usual help!

Mathieu Perron
Chargé de projet informatique et technologique

Service des technologies de l'information
Université du Québec à Chicoutimi
555, boul. de l'Université
Chicoutimi (Québec) G7H 2B1

Mathieu_Perron at uqac.ca<mailto:Mathieu_Perron at uqac.ca>


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20170413/1d8bd8fb/attachment.html 


More information about the Eprints-tech mailing list