[EP-tech] Adding Google Custom Search Engine to EPrints xpage file

John Salter J.Salter at leeds.ac.uk
Tue Oct 18 13:03:44 BST 2016

Apologies, early morning train-based emails... ‘page’ xml is what I meant (i.e. the xpage)…


From: Dan Watson [mailto:D.Watson at gold.ac.uk]
Sent: 18 October 2016 12:23
To: John Salter <J.Salter at leeds.ac.uk>; eprints-tech at ecs.soton.ac.uk
Subject: Re: Adding Google Custom Search Engine to EPrints xpage file

Thanks John.

Yes, the error was to do with namespaces. I’m new to eprints, we are reskinning it for our library team, so what/where is cage XML? I think this might be my only possible lead, otherwise I might have to give up on trying to use GCS.


Dan Watson
Web Development Manager

Goldsmiths, University of London
New Cross, London, SE14 6NW

+44 (0)207 919 7057
d.watson at gold.ac.uk<mailto:d.watson at gold.ac.uk>


From: John Salter <J.Salter at leeds.ac.uk<mailto:J.Salter at leeds.ac.uk>>
Date: Tuesday, 18 October 2016 at 07:00
To: "eprints-tech at ecs.soton.ac.uk<mailto:eprints-tech at ecs.soton.ac.uk>" <eprints-tech at ecs.soton.ac.uk<mailto:eprints-tech at ecs.soton.ac.uk>>
Cc: Dan Watson <D.Watson at gold.ac.uk<mailto:D.Watson at gold.ac.uk>>
Subject: Re: Adding Google Custom Search Engine to EPrints xpage file

What is the error that gets thrown?
Anything to do with namespaces?

I'm guessing you're putting balanced tags in - so my hunch is that the gcse: is an unrecognised name space?
If so, does registering it in the top of the cage XML help?

(Not tried any of this... - just early-morning guessing!)

From: eprints-tech-bounces at ecs.soton.ac.uk<mailto:eprints-tech-bounces at ecs.soton.ac.uk> <eprints-tech-bounces at ecs.soton.ac.uk<mailto:eprints-tech-bounces at ecs.soton.ac.uk>> on behalf of Andrew Hercules <Andrew.Hercules at ulcc.ac.uk<mailto:Andrew.Hercules at ulcc.ac.uk>>
Sent: 17 October 2016 21:55:19
To: eprints-tech at ecs.soton.ac.uk<mailto:eprints-tech at ecs.soton.ac.uk>
Cc: Dan Watson
Subject: [EP-tech] Adding Google Custom Search Engine to EPrints xpage file

Hi all,

Just wondering ... has anybody been able to implement a Google Custom Search Engine with EPrints. I noticed that ROAR attempted to do it - http://roar.eprints.org/content.html - but when I run a search, I get a 403 error.

The problem is that when the tag <gcse> is put in an xpage file, EPrints throws an error - I'm assuming it doesn't recognise the tag. Wrapping the tag in cdata tags or using JavaScript to insert the element don't work.

Any suggestions/tips would be much appreciated.

Thank you!



Andrew Hercules
Developer & UX Researcher
University of London Computer Centre
Senate House, Malet Street, London WC1E 7HU
+44 (0)20 7863 1342  |  andrew.hercules at ulcc.ac.uk<mailto:andrew.hercules at ulcc.ac.uk>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20161018/f0fc19f2/attachment-0001.html 

More information about the Eprints-tech mailing list