[EP-tech] Re: "Manage deposits" list not sorting

Adam Field af05v at ecs.soton.ac.uk
Tue Sep 15 19:44:46 BST 2015


Oooohhhh, complicated

OK, you'll need to check the user record to see which columns they have turned on, and then order by the first one, as I believe that is the one default ordering applies to.

A better idea, though, would be to figure out what's going on.

Is anyone else on the list experiencing this problem?

--
Adam Field
Business Relationship Manager and Community Lead
EPrints Services

> On 8 Sep 2015, at 14:30, Robin Sylvestre <robin.sylvestre at polymtl.ca> wrote:
> 
> Thank you Adam!
> 
> I can confirm it works better now, although there is still one thing left. 
> When we get to the "manage deposits" list, it always appears as if sorted by 
> descending eprint ids, regardless of what should be the active column. The 
> list gets sorted correctly only after we click on the column's title.
> 
> For instance, see the attached screenshots: When the page is loaded 
> (screenshot001) and what it should be (screenshot002).
> 
> Any ideas?
> 
> Robin Sylvestre
> 
> 
> 
> -----Message d'origine-----
> De : Field A.N. [mailto:af05v at ecs.soton.ac.uk]
> Envoyé : 7 septembre 2015 06:45
> À : eprints-tech at ecs.soton.ac.uk
> Objet : [EP-tech] Re: "Manage deposits" list not sorting
> 
> I've seen this issue before -- in the case I examined, it looked like the 
> _buffer_order parameter was somehow being lost.  I managed to get it working 
> with the following code in the Items plugin:
> 
> in the 'properties_from' function:
> 
>        #af05v 20150512 Workaround for immediate solution to lack of 
> ordering
>        my $order = $session->param('_buffer_order');
>        $self->{processor}->{af05v_order} = $order;
> 
> 
> in the perform_search function:
> 
>        my $list = $self->{session}->current_user->owned_eprints_list( 
> %$search, # custom_order => $search->{order}
>        #af05v 20150512 Workaround for immediate solution to lack of 
> ordering
>                custom_order => $self->{processor}->{af05v_order}
>        );
> 
> However, I didn't have time to figure out *why* this was happening.  Anyone 
> have any ideas?
> 
> --
> Adam Field
> Business Relationship Manager and Community Lead EPrints Services
> +44 (0)23 8059 8814
> 
> 
> 
> 
> 
> On 2 Sep 2015, at 17:48, Robin Sylvestre wrote:
> 
>> Hello fellow EPrinters,
>> 
>> Running version 3.3.14, we have noticed a strange behavior on the “manage 
>> deposits” screen. Items do not sort at all, when clicking on the 
>> appropriate column title (see attached screen shots). Nothing changes, 
>> only the up/down arrow appears.
>> 
>> The strange thing is that the “revision” list is not affected by this bug, 
>> only the “deposits” list.
>> 
>> I have tried to do a “epadmin reorder [archive] eprint” but that does not 
>> correct the problem. Both of our live and test versions have this problem.
>> 
>> Did anyone notice a similar bug or has a solution to offer? Thanks!!
>> 
>> 
>> 
>> Robin Sylvestre
>> Technicien en documentation
>> Bibliothèque - Services techniques et systèmes informatisés École
>> Polytechnique de Montréal
>> Tél.: 514-340-4711 poste 3743
>> 
>> <ScreenShot001.png><ScreenShot003.png>*** Options:
>> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
>> *** Archive: http://www.eprints.org/tech.php/
>> *** EPrints community wiki: http://wiki.eprints.org/
>> *** EPrints developers Forum: http://forum.eprints.org/
> 
> 
> 
> <ScreenShot001.png><ScreenShot002.png>*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
> *** EPrints developers Forum: http://forum.eprints.org/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20150915/b7eb6fcb/attachment.html 


More information about the Eprints-tech mailing list