[EP-tech] Citation count plugin

George Mamalakis mamalos at eng.auth.gr
Wed Nov 25 16:00:19 GMT 2015

Hi all,

I'm trying to install and configure the citation-count plugin in my 
EPrints 3.3.14 from: http://files.eprints.org/815/

I've tried to make things more tidy when installing it, so in my system, 
the files I added looked like this:


I've configured scopus (scapi.pl) with the codes that I was given. The 
difference from what the plugin's installation instructions (found in 
http://files.eprints.org/815/2/README) directed me to do is that I 
haven't copied the files from the plugin's /lib directly to ~eprints/lib 
folder, instead I've copied them in folders 
~eprints/lib/epm/citation-count and ~eprints/lib/plugins. When I tried 
to run:

$ ./lib/epm/citation-count/bin/import_citationdata --verbose  myrepo scopus

I got no error message, but the command returned in a couple of seconds, 
which is way too fast for my repo's size (~15K of eprints). So I 
inserted a few print commands inside 
~eprints/lib/epm/citation-count/bin/import_citationdata only to find out 
that no $session->plugin is getting defined (line 232), so the code goes 
into the condition of line 244 (if ( !defined( $plugin ) )) without 
printing any message.

I've copied ~eprints/lib/plugins/EPrints/Plugin/Import/CitationService* 
to ~eprints/perl_lib/EPrints/Plugin/ in case this was the problem 
without any luck.

Any help will be greatly appreciated!

Thanks all in advance!


George Mamalakis

IT and Security Officer,
Electrical and Computer Engineer (Aristotle Univ. of Thessaloniki),
PhD (Aristotle Univ. of Thessaloniki),
MSc (Imperial College of London)

School of Electrical and Computer Engineering
Aristotle University of Thessaloniki

phone number : +30 (2310) 994379

More information about the Eprints-tech mailing list