[EP-tech] Re: uninitialized values in default archive

Field A.N. af05v at ecs.soton.ac.uk
Tue Feb 17 14:02:18 GMT 2015


On 17 Feb 2015, at 12:50, Thomas Lauke wrote:

> Hi Adam,
> 
>> Could you paste your repository's metadata field configuration?
> Why? It's the default configuration for very new repositories generated by `epadmin create` ...

Have you installed any bazaar packages?

>> It should be in your repository's cfg.d/eprint_fields.pl file, but other fields may be 
>> added in other configuration files in cfg.d. 
> imho all configuration is done per archive, thus any cross-confusion is impossible for the very new one (by already existing and configured archives)!?

That's not strictly speaking true, though it's unusual for it to happen.


>> Also, have you added any fields using the 'manage metadata fields' front-end tool.
> never; all configuration (but _not_ for the very new one) was done in the files directly

Do you have a fresh server you could test this on?

>> Finally, have you made any changes to the perl libs in your repository?
> no, it's the original file collection of 3.3.13; but what about some conflicts with the added modules or the base perl installation ...?
> Does apache's error_log output help?
> CGI::param called in list context from package EPrints::Repository line 397, this can lead to vulnerabilities. See the warning in "Fetching the value or values of a single named parameter" at /usr/local/lib/perl5/site_perl/5.20.0/CGI.pm line 437.
> 

What distribution of Linux are you installed on?

> Many thanks for any hints in advance
> Thomas
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
> *** EPrints developers Forum: http://forum.eprints.org/




More information about the Eprints-tech mailing list