[EP-tech] Re: system unable to send email (once more !)

Laurent Cloarec Laurent.Cloarec at ut-capitole.fr
Fri Feb 13 16:44:31 GMT 2015


In the error_log, I found this :
«
Failed to create SMTP connection to smtp.univ-tlse1.fr
Wide character in print at (eval 119) line 44.
Failed to send mail.
To: cloarec at univ-tlse1.fr <>
Subject: Test email from http://ep-test.ut-capitole.fr
»
It may be a firewall problem (???)...
Nevertheles, as I wrote, I was able to send emails from the command line, using 
the Postfix installation.
Is there a way to rely on the local Postfix system instead of SMTP relay host ?


Best regards


Le 13/02/2015 16:08, Laurent Cloarec a écrit :
> Hello,
>
>
> In addition to our production server, I've just set up a test LAMP CentOS (6.x)
> server with an installation of "EPrints" (3.3.13) software.
>
> "Postfix" is configured (in /etc/postfix/main.cf, I've put the name of our SMTP
> server in the "relayhost" parameter) on this CentOS server, and I'm able to send
> emails from the command line (and receive them, of course !).
>
> In the "perl_lib/EPrints/SystemSettings.pm",I have this :
> $EPrints::SystemSettings::conf =
> {
>          'user' => 'eprints',
>          'group' => 'eprints',
>          'smtp_server' => 'xxx'
> };
> where I've tried to write, instead of "xxx", the name of our university SMTP
> server (works fine on production server) and 'localhost'
> With either value, when I try the "Send Test Email" admin tool, I receive the
> old well known "The system is currently unable to send email" message...
>
> So what's wrong ?
>
>
> Thanks, beforehand !
>
> --
> Laurent Cloarec
> Service Commun de la Documentation - Service Numérique Documentaire
> Bibliothèque Universitaire de l'Arsenal (bureau BU 017)
> Université Toulouse 1 Capitole
> 11 rue des Puits-Creusés
> 31042  TOULOUSE  Cedex 9 (France)
> tél. : (+33)(0)5.34.45.61.23



More information about the Eprints-tech mailing list