[EP-tech] Problems with IRStats and IRStats2 after 3.3.13 upgrade

Mathieu Perron mathieu_perron at uqac.ca
Wed Apr 15 14:50:06 BST 2015


I have upgraded our repository to 3.3.13 and installed IRStats2 from the 
Bazar.  I am now having some problems with IRStats and IRStats2.


When I run the following update script :
su -s /bin/sh apache -c "/eprints3/cgi/irstats.cgi eprints_uqac 
the script takes 75% of the cpu and the 25% remaining cpu is used by 
mysqld and it goes on forever.  I let the script run for a couple of days 
and it never ended.  I tried dropping all irs* tables and running the 
scripts again but it still gets stuck at the same place.


I followed the instructions to embed the stats in the abstracts.  The 
graph appears but is empty. I then looked at the source code of the page 
and saw that IRStats2 uses a pin named eprintid but it is not found in our 

Here's the culprit line of code:
var irstats2_summary_page_eprintid = '[pin missing: eprintid]';

What am I doing wrong? Why is this pin missing?

Thank you for your help and have a nice day!

More information about the Eprints-tech mailing list