[EP-tech] Multipart metadata

Gilles Fournié gilles.fournie at cirad.fr
Wed Jun 11 15:00:04 BST 2014


Hi,

I have tried to add a multipart field to our repository (3.3.12).

I modified eprint_fields.pl et ran epadmin update.
(an "eprint_test_multi" table has been created in the database)

The field declaration :

    {
         name => 'test_multi',
         type => 'multipart',
         multiple => 1,
         fields => [
             {
                 sub_name => 'motcle',
                 type => 'text',
                 allow_null => 0,
             },
             {
                 sub_name => 'id',
                 type => 'int',
                 allow_null => 0,
             }
         ],
         input_boxes => 3,
    },


But when I try to add the field in the workflow, I get an Apache 
internal error.
The log contains :

    [Wed Jun 11 15:52:23 2014] [error] XML::LibXML::Node::appendChild()
    -- nNode is not a blessed SV reference at
    /opt/www/eprints-3.3.12/perl_lib/EPrints/MetaField.pm line 1268.\n

and my addition to ,the workflow is a simple :

    <component><field ref="test_multi" /></component>

Does anybody have an idea of what causes the error ?

(I could have used a compound field but I thought that multipart was 
better as it only creates one table for all the subfields)

Thanks
Gilles





-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20140611/c937bf68/attachment.html 


More information about the Eprints-tech mailing list