[EP-tech] Breakage with IRStats2 starting at EPrints 3.3.12?

Gunnar Wolf gwolf at gwolf.org
Sat Jul 19 00:10:04 BST 2014


For the last couple of months, my stats gathering with IRStats have
not updated. I finally decided to dive in and find what happened, and
I'm almost sure it started with the update to EPrints 3.3.12.

My current IRStats page can be accessed at:


And it is obvious: Stats are not updated since early March. And, of
course, according to /usr/share/doc/eprints/changelog.gz (in a Debian
system), 3.3.12 was uploaded on March 06 (modulo a couple of days that
it took me to update). Note that I didn't change anything from the
version that used to work.

When I run the stats updating script
($ARCHIVE_ROOT/bin/stats/process_stats), I get the following output:

---------------- EPrints System Error ----------------------------
Error in configuration:
Can't call method "add_trigger" on unblessed reference at /usr/share/eprints3/archives/iiec/bin/../cfg/cfg.d/media_info.pl line 79.

Now, $c *is* assigned, but not to a "blessed" object (it's just a hash
ref). I tried blessing it into a EPrints::RepositoryConfig, but
without going through it as a constructor, it's no wonder it failed to

Where should I look to get my stats working again?


More information about the Eprints-tech mailing list