[EP-tech] Re: A specific eprint doesn't get indexed

franc at library.iisc.ernet.in franc at library.iisc.ernet.in
Fri Oct 11 11:07:39 BST 2013


Hi Seb, Thanks for the instant response. My inline reply follows.

On Fri, 11 Oct 2013, Sebastien Francois wrote:

> Hi Francis,
>
> I notice your repository is not using the Xapian search engine - if you wish 
> to use it, check this out: 
> http://wiki.eprints.org/w/New_Features_in_EPrints_3.3#Search_engine_plugins

I'll plan to switch over to Xapian in due course of time.

I have tried other options that you have suggested:
>
> If not, you may:
>
> 1- look at the indexer logs for errors on that eprint (var/indexer.log)
>
The log file doesn't report any error messages

> 2- look at the eprint__* tables in the database to see if there are any index 
> codes for that eprint
>
eprint__rindex.MYI has crashed. I'm trying to fix it. How is it that I'm 
able to search and retrieve other eprints? Only 47379 is problematic.

> 3- try "reindex" with verbose and let us know of any errors/warnings
>
I have tried this, no errors reported:

bin/epadmin reindex iisceprints eprint 47379 --verbose

Starting EPrints Repository.
Connecting to DB ... done.
Indexed item: eprint/47379


> Seb.
>
>
> On 11/10/13 09:19, franc at library.iisc.ernet.in wrote:
>>  I have noticed that a specific eprint, http://eprints.iisc.ernet.in/47379/
>>  id not getting indexed. Repeated attempts to re-index it using the
>>  command,
>>  bin/epadmin reindex repoid eprint 47379 is not helping. The only way this
>>  item can be retrieved is through the admin->search items->Username
>>  interface.
>>
>>  How do I get this item indexed so that it can retrieved through the simple
>>  and advanced searches?
>>
>>  Many thanks for your attention.
>>
>>     - Francis
>>
>>  JRD Tata Library
>>  IISc
>>  Bangalore, India
>> 
>> 
>> 
>
>
>

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.



More information about the Eprints-tech mailing list