[EP-tech] Using soft-linked storage location for documents

Caldow, James JCaldow at qmu.ac.uk
Fri Oct 4 11:58:34 BST 2013


Hi,

I am hoping someone can offer some advice, as I have a problem which has dragged on for some time now.

We have a replacement repository in progress in which the decision was taken to have the documents folder soft-linked to a separate drive. This was done with the intention of allowing easier expansion in the future and splitting content from the main software for archival purposes.

I have installed the base eprints software, added the storage location to the system, created the soft-link, etc. Unfortunately, while the server recognises the storage location, I don't have the same luck with eprints. I've altered the permissions as best I understand them, and have carried out the necessary SELINUX changes.

The current structure and permissions are:

drwxrwsr-x    eprints eprints    documents

Then:

lrwxrwxrwx    apache eprints    disk0 -> /mnt/[repoid]/data

I've also run:

chcon -R -h -t httpd_sys_script_rw_t /usr/share/eprints/archives/[repoid]/documents

I have also tried changing ownership of the disk0 folder to eprints:eprints with the same effect.

This is all on a server running CentOS 6.4.

As I mentioned previously, the server has no problem accessing the mounted storage but eprints seems not to recognise it. If I visit the admin pages and view status I get the following error:

No storage directories found in /usr/share/eprints/archives/[repoid]/documents

I have tested reverting the document storage back to the default location under the eprints installation and all works perfectly. It is only when I try to move the documents outside of this location that I encounter an error. Am I trying to do something impossible, or have I missed something obvious?

Any and all advise would be gratefully received as this is really holding us back.


Kind regards,

James


More information about the Eprints-tech mailing list