[EP-tech] Re: default.xml

John Salter J.Salter at leeds.ac.uk
Thu May 2 11:57:35 BST 2013


Has there been any patches applied to the server recently? If it's a RHEL or CentOS server a recent update to LibXML may cause a template (and phrase files) that contain entities not to parse - thereby making the system fall back to the default (global) template.
If there are any html entities in your template (anything like ©   ), replace them with their numeric equivalent.
This would also be logged in your Apache error log - which is a good place to look for hints about what isn't working properly now!

Cheers,
Johm

From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of keerthana reddy
Sent: 02 May 2013 11:45
To: eprints-tech at ecs.soton.ac.uk
Subject: [EP-tech] Re: default.xml

Every thing was alright before. I could see the structure of the template on the browser as i defined it in archiveid/cfg/lang/en/templates/default.xml and i never touched the global template. Even there is nothing as such in my eprints3/lib/templates. What ever changes i used to do in repository specific template, they reflected on the browser. But i recently tried to remove the browse by subjects class and then after reloading, it has become the default template. Now nothing is getting happened even if i remove the default.xml from the templates.

Regards
M.Keerthana

On Thu, May 2, 2013 at 3:41 PM, Ian Stuart <Ian.Stuart at ed.ac.uk<mailto:Ian.Stuart at ed.ac.uk>> wrote:
On 02/05/13 11:02, keerthana reddy wrote:
> Hi, there was an extra tag and i removed it and i ran static. But still
> there is no change in the archive even when i remove default.xml
Are any of your changes showing?
 From a previous comment, it is possible that EPrints is taking a
dislike to archiveid/cfg/lang/en/template/default.xml and using the
system-default one

Can you load default.xml into a browser windows directly (this should
show that its well-formed, at least)
--

Ian Stuart.
Developer: ORI, RJ-Broker, and OpenDepot.org
Bibliographics and Multimedia Service Delivery team,
EDINA,
The University of Edinburgh.

http://edina.ac.uk/

This email was sent via the University of Edinburgh.

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
*** Archive: http://www.eprints.org/tech.php/
*** EPrints community wiki: http://wiki.eprints.org/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20130502/421159d8/attachment.html 


More information about the Eprints-tech mailing list