[EP-tech] Re: SWORD and Eprints 3.2 - **SOLVED**

Ian Stuart Ian.Stuart at ed.ac.uk
Thu Jan 24 11:56:37 GMT 2013


On 24/01/13 11:05, Tian, Jia wrote:

> The SWORD 1.3 I had worked last April on EPrints v3.2.x and it works
> very straightforward without particular configurations. I pasted my
> sword.pl here for your reference.
Thanks for that... yep - it's a basically standard sword.pl document.

> Which user role did you give to your test account? We are using an
> editor account. Probably you can try an editor account. Let me know
> anything I could help please.
Nope - its a normal user account.... just like the other normal user 
accounts I have, that CAN authenticate.

What I have discovered it there are two gotcha's here:

1) The username must be [a-zA-Z_] .... 'test-user' fails, 'test_user' is 
OK (both can log in though)
2) the password seems to also be Perl word-characters '*password*' 
fails, 'qiwueyqw234' is OK (likewise, both can log in)

I'm guessing this is an issue in a handler routine somewhere

-- 

Ian Stuart.
Developer: ORI, RJ-Broker, and OpenDepot.org
Bibliographics and Multimedia Service Delivery team,
EDINA,
The University of Edinburgh.

http://edina.ac.uk/

This email was sent via the University of Edinburgh.

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.



More information about the Eprints-tech mailing list