[EP-tech] Re: Eprints 3.3.6 on CentOS 6.3 - Exports of Citations not working

Adams, Thomas tadams at cshl.edu
Thu Jan 17 19:47:24 GMT 2013


Thanks for pinpointing the solution.

The problem was solved by making the single line change in the perl_lib/EPrints/Plugin/Screen/Search.pm file as show in Changeset 7686 to my EPrints 3.3.6 instance.  I assume upgrading to EPrints 3.3.10 would have also solved the problem.


-----Original Message-----
From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Tim Brody
Sent: Thursday, January 17, 2013 4:58 AM
To: eprints-tech at ecs.soton.ac.uk
Subject: [EP-tech] Re: Eprints 3.3.6 on CentOS 6.3 - Exports of Citations not working

On Fri, 11 Jan 2013 22:12:36 +0000, "Adams, Thomas" <tadams at cshl.edu>
> After performing a simple search (from the menu bar) in Eprints, the 
> "Export" button seems to replace the URL in the browser, with another 
> URL but the page contents remain unchanged.
> Initial simple search URL, (searching for james):
> After pressing "ASCII Citation" Export, the URL is changed to:
> The content of the page remain the same.
> If I then press "BibTex" Export, the URL becomes:
> The content of the page remains the same (the initial simple search), 
> not the expect "ACSII Citation". So I am not sure, if Eprints is 
> building the URL correctly.
> It gets a little more interesting when I "ASCII Citation" Export on a 
> "Browse by Year" page. Here the listing initially appears to work, 
> displaying the whole page of citation within the browser, but right at
> end of the page gets loaded again and only three of the entries remain.
> Strange.
> However, the BibTex export seems OK when performed from the "Browse by 
> Year".
> Background:
> I'm running Eprints 3.3.6 on CentOS6.3, which had been recently 
> upgraded from CentOS 6.0. Since the upgrade, I needed to modify the   
> entities in the system.xml file. Did not downgrade the libxml2 nor libxml2-python.
> BTW - the BibTex and all other export modules are  displaying within 
> the browser (Firefox) screen, should they not be forced to a save-as 
> file dialog.


You've been bitten by a change in how the URI module works. If you notice all the '&'s have been turned into 'n's.

There was a fix for this in Search.pm:

All the best,
*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
*** Archive: http://www.eprints.org/tech.php/
*** EPrints community wiki: http://wiki.eprints.org/

More information about the Eprints-tech mailing list