[EP-tech] Re: EPrints 3.3.10 problem - unable to edit metadata fields

Alan.Stiles Alan.Stiles at open.ac.uk
Fri Feb 8 15:59:58 GMT 2013


Hi Bruno,

I thought you were trying to create a function accessing the eprint dataset, but are you actually accessing the web administration interface?

Admin -> Config Tools -> Manage Metadata Fields -> 'View Dataset Fields' on the Eprints dataset?

The not very helpful suggestion would be to try amending the appropriate file in cfg.d to add the field, but obviously this doesn't explain the error message.  Is there anything in your apache error_log?

Alan

________________________________
From: Bruno Matos Saraiva [mailto:bruno.matos.saraiva at gmail.com]
Sent: 08 February 2013 15:06
To: eprints-tech at ecs.soton.ac.uk
Subject: [EP-tech] Re: EPrints 3.3.10 problem - unable to edit metadata fields

Hi Alan

Well, it's a "fresh" EPrints instalation, it has no content yet, and it has always produced this kind of error.
One curious thing is that the same error occurs using Demoprints in the same circumstances.
The code of the function you refer to is in the eprints_fields.pl<http://eprints_fields.pl> file?

Thanks.
Regards,
Bruno


On 8 February 2013 13:59, Alan.Stiles <Alan.Stiles at open.ac.uk<mailto:Alan.Stiles at open.ac.uk>> wrote:
Hi Bruno,
It looks like something in the code isn't defined correctly, but you will need to share more of the code of the function you are trying to write for anyone to be able to help you.

regards,

Alan
(ORO Developer, Library Services, The Open University)

________________________________
From: Bruno Matos Saraiva [mailto:bruno.matos.saraiva at gmail.com<mailto:bruno.matos.saraiva at gmail.com>]
Sent: 08 February 2013 12:53
To: eprints-tech at ecs.soton.ac.uk<mailto:eprints-tech at ecs.soton.ac.uk>
Subject: [EP-tech] EPrints 3.3.10 problem - unable to edit metadata fields


Hello all

When I try to view dataset fields of "Eprints" to edit them, the system generates the following error message:


EPrints System Error

Attempt to get value from not existent field: metafield/objectid


Even when I try to create/edit a field in a dataset that allows me to enter (I've tried them all), it displays the same error.

Any suggestions to solve this?

Thank you.

Best regards,

Bruno Saraiva | Museu da Presidência da República

--
The Open University is incorporated by Royal Charter (RC 000391), an exempt charity in England & Wales and a charity registered in Scotland (SC 038302).

*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
*** Archive: http://www.eprints.org/tech.php/
*** EPrints community wiki: http://wiki.eprints.org/


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20130208/04847121/attachment.html 


More information about the Eprints-tech mailing list