[EP-tech] upgrade error from 3.3.7 to 3.3.8

ARIFFIN KUSETIAWAN BIN MUKANDAR ariffin at iium.edu.my
Wed Aug 21 09:29:02 BST 2013


Greetings,

While trying to upgrade our repository from 3.3.7 to 3.3.8 this error message occurred..

bash-3.2$ ./epadmin upgrade iiumprints
Can't locate Digest/SHA.pm in @INC (@INC contains: /opt/eprints3/lib/plugins /opt/eprints3/bin/../perl_lib /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at /opt/eprints3/bin/../perl_lib/EPrints/Utils.pm line 61.
BEGIN failed--compilation aborted at /opt/eprints3/bin/../perl_lib/EPrints/Utils.pm line 61.
Compilation failed in require at /opt/eprints3/bin/../perl_lib/EPrints.pm line 270.
BEGIN failed--compilation aborted at /opt/eprints3/bin/../perl_lib/EPrints.pm line 270.
Compilation failed in require at ./epadmin line 250.
BEGIN failed--compilation aborted at ./epadmin line 250.

bash-3.2$

I am not sure what caused the error and how to fix it. I would appreciate any help.

Thank you.


Ariffin Kusetiawan Mukandar
System Administrator
International Islamic University Malaysia
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20130821/ef77bcfc/attachment.html 


More information about the Eprints-tech mailing list