[EP-tech] Eprints installation error

Alex Birchall A.Birchall at mdx.ac.uk
Wed Sep 19 11:48:07 BST 2012


Hi,

I am getting the error below when installing eprints:

root at eprints:/# apt-get install eprints
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gnome-utils-common libcdio10 pnm2ppa libcolamd2.7.1 lp-solve
  gir1.2-gconf-2.0 gnome-desktop-data libunity6 libindicator6 libgdata1.7-cil
  libapt-pkg4.11 hplip-cups unity-2d-launcher libglew1.5 libproxy0 libgexiv2-0
  linux-headers-3.0.0-26 libgtkspell3-0 libglewmx1.5 libminiupnpc5
  libnux-1.0-0 libpoppler13 python-telepathy cups-driver-gutenprint
  libpolkit-gtk-1-0 libgmime2.4-cil libgssdp-1.0-2 libnux-1.0-common
  python-webkit libcdio-cdda0 libhunspell-1.2-0 libept1 gir1.2-dee-0.5
  libgmime-2.4-2 libunique-1.0-0 libdee-1.0-1
  linux-headers-3.0.0-26-generic-pae libtextcat0 zeitgeist-extension-fts
  libtextcat-data libquvi0 libexiv2-10 libcdio-paranoia0 libgupnp-1.0-3 libnl3
  icc-profiles-free python-wnck libapt-inst1.3 libindicator3-6
  libnautilus-extension1 min12xxw libnatpmp1 libgupnp-igd-1.0-3
  unity-2d-places linux-headers-3.0.0-26-generic libllvm2.9 libpoppler-glib6
  python-indicate
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  elinks elinks-data libcommon-sense-perl libfsplib0 libjson-perl
  libjson-xs-perl liblua50 liblualib50 libreadline5 libruby1.8
  libsearch-xapian-perl libtre5
Suggested packages:
  elinks-doc xapian-doc tre-agrep
The following NEW packages will be installed:
  elinks elinks-data libcommon-sense-perl libfsplib0 libjson-perl
  libjson-xs-perl liblua50 liblualib50 libreadline5 libruby1.8
  libsearch-xapian-perl libtre5
The following packages will be upgraded:
  eprints
1 upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 6,753 kB of archives.
After this operation, 13.3 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
WARNING: The following packages cannot be authenticated!
  eprints
Install these packages without verification [y/N]? y
Get:1 http://deb.eprints.org/ stable/ eprints 3.3.10 [3,097 kB]
Get:2 http://gb.archive.ubuntu.com/ubuntu/ precise/main libjson-perl all 2.53-1 [93.7 kB]
Get:3 http://gb.archive.ubuntu.com/ubuntu/ precise/universe libfsplib0 i386 0.11-2 [13.3 kB]
Get:4 http://gb.archive.ubuntu.com/ubuntu/ precise/universe liblua50 i386 5.0.3-6 [55.8 kB]
Get:5 http://gb.archive.ubuntu.com/ubuntu/ precise/universe liblualib50 i386 5.0.3-6 [36.8 kB]
Get:6 http://gb.archive.ubuntu.com/ubuntu/ precise/main libreadline5 i386 5.2-11 [123 kB]
Get:7 http://gb.archive.ubuntu.com/ubuntu/ precise/main libruby1.8 i386 1.8.7.352-2ubuntu1 [1,781 kB]
Get:8 http://gb.archive.ubuntu.com/ubuntu/ precise/universe libtre5 i386 0.8.0-2 [60.4 kB]
Get:9 http://gb.archive.ubuntu.com/ubuntu/ precise/universe elinks-data all 0.12~pre5-7ubuntu1 [590 kB]
Get:10 http://gb.archive.ubuntu.com/ubuntu/ precise/universe elinks i386 0.12~pre5-7ubuntu1 [549 kB]
Get:11 http://gb.archive.ubuntu.com/ubuntu/ precise/universe libsearch-xapian-perl i386 1.2.8.0-2 [252 kB]
Get:12 http://gb.archive.ubuntu.com/ubuntu/ precise/main libcommon-sense-perl all 3.4-1 [20.7 kB]
Get:13 http://gb.archive.ubuntu.com/ubuntu/ precise/main libjson-xs-perl i386 2.320-1build1 [80.5 kB]
Fetched 6,753 kB in 0s (7,363 kB/s)                                      
Selecting previously unselected package libjson-perl.
(Reading database ... 226231 files and directories currently installed.)
Unpacking libjson-perl (from .../libjson-perl_2.53-1_all.deb) ...
Selecting previously unselected package libfsplib0.
Unpacking libfsplib0 (from .../libfsplib0_0.11-2_i386.deb) ...
Selecting previously unselected package liblua50.
Unpacking liblua50 (from .../liblua50_5.0.3-6_i386.deb) ...
Selecting previously unselected package liblualib50.
Unpacking liblualib50 (from .../liblualib50_5.0.3-6_i386.deb) ...
Selecting previously unselected package libreadline5.
Unpacking libreadline5 (from .../libreadline5_5.2-11_i386.deb) ...
Selecting previously unselected package libruby1.8.
Unpacking libruby1.8 (from .../libruby1.8_1.8.7.352-2ubuntu1_i386.deb) ...
Selecting previously unselected package libtre5.
Unpacking libtre5 (from .../libtre5_0.8.0-2_i386.deb) ...
Selecting previously unselected package elinks-data.
Unpacking elinks-data (from .../elinks-data_0.12~pre5-7ubuntu1_all.deb) ...
Selecting previously unselected package elinks.
Unpacking elinks (from .../elinks_0.12~pre5-7ubuntu1_i386.deb) ...
Selecting previously unselected package libsearch-xapian-perl.
Unpacking libsearch-xapian-perl (from .../libsearch-xapian-perl_1.2.8.0-2_i386.deb) ...
Selecting previously unselected package eprints.
Preparing to replace eprints 3.2.8 (using .../eprints_3.3.10_all.deb) ...
Unpacking replacement eprints ...
apache2: Syntax error on line 233 of /etc/apache2/apache2.conf: Could not open configuration file /usr/share/eprints3/cfg/apache.conf: No such file or directory
Action 'restart' failed.
The Apache error log may have more information.
dpkg: warning: subprocess old post-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
 Removing any system startup links for /etc/init.d/epindexer ...
Removing user `eprints' ...
Done.
Removing group `eprints' ...
Done.
apache2: Syntax error on line 233 of /etc/apache2/apache2.conf: Could not open configuration file /usr/share/eprints3/cfg/apache.conf: No such file or directory
Action 'restart' failed.
The Apache error log may have more information.
dpkg: error processing /var/cache/apt/archives/eprints_3.3.10_all.deb (--unpack):
 subprocess new post-removal script returned error exit status 1
 Removing any system startup links for /etc/init.d/epindexer ...
/usr/sbin/deluser: The user `eprints' does not exist.
dpkg: error while cleaning up:
 subprocess new post-removal script returned error exit status 2
Selecting previously unselected package libcommon-sense-perl.
Unpacking libcommon-sense-perl (from .../libcommon-sense-perl_3.4-1_all.deb) ...
Selecting previously unselected package libjson-xs-perl.
Unpacking libjson-xs-perl (from .../libjson-xs-perl_2.320-1build1_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Errors were encountered while processing:
 /var/cache/apt/archives/eprints_3.3.10_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I did google this error and found a supposed fix which involved looking at the file /var/lib/dpkg/info/eprints.postrm (see http://www.eprints.org/tech.php/thread-12622.html).  But this does not appear to be the problem here.

Any suggestions:

Best regards,

Alex
Alexander J Birchall, Library Systems Manager, The Sheppard Library, Middlesex University, London NW4 4BT

Tel +44 (0) 208 411 5235
Mobile:  07765 237 570




---------------------------------------------------------------------------


Please note that Middlesex University's preferred way of receiving all correspondence is via email in line with our Environmental Policy. All incoming post to Middlesex University is opened and scanned by our digital document handler, CDS, and then emailed to the recipient.
 
If you do not want your correspondence to Middlesex University processed in this way please email the recipient directly. Parcels, couriered items and recorded delivery items will not be opened or scanned by CDS.  There are items which are "exceptions" which will be opened by CDS but will not be scanned a full list of these can be obtained by contacting the University.




More information about the Eprints-tech mailing list