[EP-tech] Re: Update EPrints 3.1.1 - 3.3.10

Tim Brody tdb2 at ecs.soton.ac.uk
Wed Sep 5 13:43:08 BST 2012


On Wed, 29 Aug 2012 11:05:44 +0000, "Dindar, Cengiz"
<cengiz.dindar at mdc-berlin.de> wrote:
> I have a Problem, can you help me?
> 
> On my current server I have an old version of EPrints 3.1.1 and want to
> upgrade to the new version of EPrints3.3.10 make SLES11sp1 server.
> 
> 
> 1.       Preinstall
> What version of MySQL, Apache, PHP, Perl and mod_perl can be compiled by
> EPrints 3.3.10?

MySQL 5+
mod_perl >= 2.0

You shouldn't install PHP unless you need for other services.

> 2.       compile
> Which flags are set at compile?

Nothing specific ...

> 3.       Other Application
> If you need any other applications? libxml, PCRE, SQLite Library?

XML::LibXML. There is a number of helper applications that you will need.

Unless you have a burning desire to compile from source, use a package
manager and install EPrints using the RPM (or use the RPM to load the
dependencies and install from .tar.gz).

> 4.       Range
> Between steps are necessary?
> 3.1.1 -> 3.2.9 -> 3.3.10

EPrints *should* upgrade itself from any 3.x version.

-- 
All the best,
Tim.


More information about the Eprints-tech mailing list