[EP-tech] Re: Bug in ePrints 3.3.10?

Caldow, James JCaldow at qmu.ac.uk
Wed Nov 7 09:21:29 GMT 2012


Ah, many thanks for that, John.

I couldn't find anything relating to it and was worried it was either something I'd done or something that had been missed in the latest update. I'm glad it's a known issue and, hopefully, it will be resolved soon.

At least it can be worked around.

Regards,

JamesJohn Salter <J.Salter at leeds.ac.uk> wrote:James,
This is due to an update to LibXML - which now doesn't seem to pull in the system entities properly.
I ran into the same issue recently when someone applied some security patches to my RHEL6 server without telling me - and everything went very awry.

This call has been raised: https://bugzilla.redhat.com/show_bug.cgi?id=863166

This thread: http://www.eprints.org/tech.php/17090.html also describes this issue.

Cheers,
John


-----Original Message-----
From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Caldow, James
Sent: 06 November 2012 14:01
To: eprints-tech at ecs.soton.ac.uk
Subject: [EP-tech] Re: Bug in ePrints 3.3.10?

Sorry, the email formatting has stripped the solution entity. For the space character the change made was entity &#160 in place of &nbsp.

Apologies for any confusion caused!


James Caldow



-----Original Message-----
From: eprints-tech-bounces at ecs.soton.ac.uk on behalf of Caldow, James
Sent: Tue 11/6/2012 13:41
To: EPrints.org Technical List
Subject: [EP-tech]  Bug in ePrints 3.3.10?

Hi,

After a number of unsuccessful attempts to install 3.3.10, I wanted to ask if the following was a known bug:

The file lib/lang/en/phrases/system.xml contains three occurrences of "&nbsp;", (two on line 396 and one on line 3006).

On a clean installation of CentOS 6.3 and 3.3.10, attempting to run bin/epadmin create resulted in multiple errors regarding parsing of the above file and created an archive with multiple broken links and "phrase not defined" errors.

Changing the three occurrences of "&nbsp;" to " " resulted in a clean build and no errors.

I don't currently have another test environment on which to confirm these errors, so would appreciate any input on whether this bug only exists as a result of the OS environment, or if it is a genuine bug in the 3.3.10 release. I do know that XML doesn't support "&nbsp;", so would assume this will be a problem for all.


Regards,


James Caldow

_______________________________

James Caldow

Educational Resource Centre
Queen Margaret University
Queen Margaret University Drive
Musselburgh
EH21 6UU

Tel: 0131 474 0000
Fax: 0131 474 0001
E-Mail: jcaldow at qmu.ac.uk



*** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
*** Archive: http://www.eprints.org/tech.php/
*** EPrints community wiki: http://wiki.eprints.org/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20121107/c239b36b/attachment.html 


More information about the Eprints-tech mailing list