[EP-tech] database conversion error, while upgrading 3.1.0 -> 3.3.10

Matthew Brady Matthew.Brady at usq.edu.au
Wed Nov 7 01:26:34 GMT 2012


Hi everyone,

I am performing an upgrade to a copy of our ePrints repository, which is currently 3.1.0 and has had quite a bit added to the datasets over the years, to iron out the process and check for problems...

I found one.. Details below..  Any ideas on where to start looking would be appreciated.

Also, can I re-run the epadmin upgrade process from the state it's in now (1/2 completed) , or do I need to refresh the machine and do it all from scratch..

Thanks

Matt



Using the tarball, for 3.3.10,

*         ./configure worked fine,

*         ./install worked fine (created lots of backup files as it went, but that was expected.)

*         Jumped into mysql to empty out some __rindex tables (as documented on http://wiki.eprints.org/w/Upgrading_from_3.1)

*         bin/epadmin upgrade <repoid>

Upgrading 3.1.2 to 3.2.0
There are recommended configuration file updates:
        indexing.pl
        rdf_license.pl
Install updated configuration files? [yes/no] ? yes
Renaming /opt/eprints3/archives/<repoid>/cfg/cfg.d/indexing.pl to indexing.pl.old

Added dataset saved_search

Fixed saved_search__rindex.field collation

Added dataset document

Added placement to dataset document
...
...
Upgrading dataset eprint
Upgrading `eprint` by insertion
DBD::mysql::db do failed: Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. You have to change some columns to TEXT or BLOBs at /opt/eprints3/bin/../perl_lib/EPrints/Database.pm line 3051, <STDIN> line 1.
SQL ERROR (do): ALTER TABLE `new_eprint` CONVERT TO CHARACTER SET utf8 COLLATE utf8_bin
SQL ERROR (do): Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. You have to change some columns to TEXT or BLOBs (#1118)

------------------------------------------------------------------
---------------- EPrints System Error ----------------------------
------------------------------------------------------------------
Error creating table `new_eprint` based on `eprint`
------------------------------------------------------------------
EPrints System Error inducing stack dump
at /opt/eprints3/bin/../perl_lib/EPrints.pm line 145
        EPrints::abort() called at bin/epadmin line 2664
        main::upgrade_mysql_charset_table('EPrints::Repository=HASH(0x2e86890)', 'EPrints::Database::mysql=HASH(0x388aaf0)', 'eprint', 'ARRAY(0x2e3f838)') called at bin/epadmin line 2561
        main::upgrade_mysql_charset('EPrints::Repository=HASH(0x2e86890)', 'EPrints::Database::mysql=HASH(0x388aaf0)') called at bin/epadmin line 2873
        main::upgrade_3_1_2_to_3_2_0('EPrints::Repository=HASH(0x2e86890)', 'EPrints::Database::mysql=HASH(0x388aaf0)') called at bin/epadmin line 2752
        main::upgrade('usqep3') called at bin/epadmin line 312
[eprints at devserver02 eprints3]$





This email (including any attached files) is confidential and is for the
intended recipient(s) only.  If you received this email by mistake,
please, as a courtesy, tell the sender, then delete this email.

The views and opinions are the originator's and do not necessarily
reflect those of the University of Southern Queensland.  Although all
reasonable precautions were taken to ensure that this email contained no
viruses at the time it was sent we accept no liability for any losses
arising from its receipt.

The University of Southern Queensland is a registered provider of education
with the Australian Government.
(CRICOS Institution Code QLD 00244B / NSW 02225M, TEQSA PRV12081 )


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20121107/60513207/attachment-0001.html 


More information about the Eprints-tech mailing list