[EP-tech] Re: #include in Eprints 3.3.9 // error

Centro de Documentación cendocu at gmail.com
Thu May 24 12:08:45 BST 2012


Hi Sebastien,

Many thanks for your quick answer.

Could you give me an example using an Ajax callback?

Regards,

Cristian




On Thu, May 24, 2012 at 7:09 AM, Sebastien Francois <sf2 at ecs.soton.ac.uk> wrote:
> Hi,
>
> That kind of problems is caused by the Lightbox (JS library used by
> EPrints) being loaded twice. Have a look at the source of your example
> page: you will see that instead of returning an HTML fragment, the
> #include /cgi/latest_tool returns the entire page - so my guess here is
> that the param "?mainonly=yes" got lost on the way.
>
> We've had many troubles with using #include too (mostly because of
> params not being passed properly to the CGI), we're using a simple Ajax
> callback now instead.
>
> Seb.
>
> On 24/05/12 01:31, Centro de Documentación wrote:
>> Here you can see what happens
>>
>> http://nulan.mdp.edu.ar/test.html
>>
>>
>> ---------- Forwarded message ----------
>> Subject: #include in Eprints 3.3.9
>> To: eprints-tech at ecs.soton.ac.uk
>>
>>
>> Hi,
>>
>> If I use<!--#include virtual="/cgi/latest_tool?mainonly=yes"-->  on my
>> index.xpage the template is corrupted.
>>
>> In EP 3.2.6 worked well.
>>
>> Does anyone know what happened?
>>
>> Thanks,
>>
>> Cristian
>> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
>> *** Archive: http://www.eprints.org/tech.php/
>> *** EPrints community wiki: http://wiki.eprints.org/
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/



More information about the Eprints-tech mailing list