[EP-tech] Re: "request a copy" button

Denis Pitzalis - STARC d.pitzalis at cyi.ac.cy
Thu May 10 14:53:10 BST 2012


Hi Tim,

according to request_copy.pl if there is no contact email, I can
define the user:
	my ( $repository, $eprint ) = @_;
	if( $eprint->is_set("contact_email") )
	{
		return $eprint->value("contact_email");
	}
	my $user = $eprint->get_user;
	if( defined $user && $user->is_set( "email" ) )
	{
		return $user->value( "email" );
	}

Denis

On Thu, May 10, 2012 at 12:06 PM, Tim Brody <tdb2 at ecs.soton.ac.uk> wrote:
> On Wed, 2012-05-09 at 12:23 +0200, Denis Pitzalis - STARC wrote:
>> Dear all,
>> I've set the request a copy button to request the source images when
>> available but when I click the button I get a big, red:
>> Bad parameters. Do not try and access this script directly.
>>
>> what am I doing wrong?
>
> We will need more information ... I've just tested this on trunk and it
> all works. You need to have a "contact_email" in the eprint record and
> that email needs to a valid email address for a user.
>
>
> --
> All the best,
> Tim
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
>



-- 
----------------------
Denis Pitzalis
Information Technology Consultant

UNESCO - http://www.unesco.org
Paris, France - Tel: +33145681816

Business Strand Coordinator
3D-COFORM - http://www.3dcoform.eu

VAST 2011 - http://www.vast-conference.eu


More information about the Eprints-tech mailing list