[EP-tech] Re: Can't send account activation mail

Tim Brody tdb2 at ecs.soton.ac.uk
Tue Mar 13 16:22:56 GMT 2012


On Mon, 2012-03-12 at 09:44 +0530, Chander Shekhar wrote:
> while installing the Eprints 3.2.8  on centos 6
> platform i encoutered a problem. There is a module for new user
> registration which is followed by approval through link in the mail. But
> the system is showing the error:
> 
> "The system is currently unable to send email. Please try again later. If
> this problem persists, please contact the administrator with details."

There is a 'Test Email' function under Admin that you can use to test
whether you can send email.

Your SMTP server is defined in perl_lib/EPrints/SystemSettings.pm with
"smtp_server". That particular error occurs when
Net::SMTP->new( $smtphost ) fails.

That suggests that either the eprints user can't access your SMTP server
or the SMTP server is rejecting the connection. Either way, your mail
admin should be able to tell you what's going wrong.

(You may also try adding 'Debug   => 1,' to the SMTP->new in
perl_lib/EPrints/Email.pm)

All the best,
Tim.

> here's is the apache error_log (192.168.x.x is our internal mails server)
> 
> Failed to create smtp connection to 192.168.x.x
> Failed to send mail.
> To: bls at ceeri.ernet.in <mr bls bls>
> Subject: Registration
> 
> Failed to create smtp connection to 192.168.x.x
> Failed to send mail.
> To: bls at ceeri.ernet.in <mr bls lkm>
> Subject: Registration
> 
> 
> but its (system) establishing the smtp connection via telnet on port 25 to
> 192.168.x.x from the shell, and infact can send the mail.
> 
> Please suggest and help.
> 
> 
> 
> 




More information about the Eprints-tech mailing list