[EP-tech] Re: Uploading a file issue

Sebastien Francois sf2 at ecs.soton.ac.uk
Fri Mar 9 12:56:06 GMT 2012


Do you have a secure template (secure.xml)? If so, does the secure 
template include the same JS files?

Depending on which version of EPrints you're using, secure.xml should 
include /javascript/secure_auto.js instead of /javascript/auto.js.

Seb.

On 09/03/12 12:39, Lee Paton wrote:
> Thanks Tim
>
> You should be able to access my pastebin now
>
> 1. This is what I have in my workflow
>
> <stage name="files">
> <component type="Upload" show_help="always" />
> <component type="Documents">
> <field ref="content" />
> <field ref="format" />
> <field ref="formatdesc" />
> <field ref="security" />
> <field ref="license" />
> <field ref="date_embargo" />
> <!-- <field ref="relation" /> -->
> <!-- <field ref="language" /> -->
> </component>
> </stage>
>
> 2. <scripts> in <head> are:
>
> <script type="text/javascript" async="" src="https://ssl.google-analytics.com/ga.js"> 
>
> <script src="/javascript/auto.js" type="text/javascript">
> <script src="/javascript/jscss.js" type="text/javascript">
>
> The following is at the top of my auto.js
>
> var eprints_http_root = "http:\/\/eprints-dev.cf.ac.uk 
> <http:////eprints-dev.cf.ac.uk>";
> var eprints_http_cgiroot = "http:\/\/eprints-dev.cf.ac.uk\/cgi 
> <http:////eprints-dev.cf.ac.uk//cgi>";
>
> I'm guessing that this is part of the problem?
>
> Lee
>
> Lee Paton
> Information Services
> Cardiff University
> 40-42 Park Place
> Cardiff
> CF10 3BB
>
>
>
> From: Tim Brody <tdb2 at ecs.soton.ac.uk>
> To: <eprints-tech at ecs.soton.ac.uk>
> Date: 09/03/2012 11:59
> Subject: [EP-tech] Re: Uploading a file issue
> Sent by: eprints-tech-bounces at ecs.soton.ac.uk
> ------------------------------------------------------------------------
>
>
>
> How do I access a 'private' pastebin?
>
> Anyway, this looks like a problem between HTTP/HTTPS. Your HTTPS workflow
> is attempting to call an HTTP AJAX callback, which is unlikely to work
> correctly.
>
> As Seb has roughly outlined we need to confirm the following:
>
> 1) Your workflow.xml contains (ignoring help="" or similar attributes):
> <component type="Upload" />
> <component type="Documents">
> ... list of fields
> </component>
>
> 2) What Javascript is being loaded by your Workflow:
> What is in the <head> of the HTML page? <script>s
> What is at the top of the linked-to auto.js (or secure_auto.js)? It should
> be setting the eprint_* vars to point to https://?.
>
>
> Or, if you can give me access to your server I can work these things out
> myself.
>
> /Tim.
>
> On Fri, 9 Mar 2012 11:23:15 +0000, Lee Paton <PatonL at cardiff.ac.uk> wrote:
> > Hi Tim
> >
> > Yes, I am - I include the .conf file http://pastebin.com/PvpH2gCein my
> > main http.conf file and this includes the generated .conf in
> > cfg/apache_ssl/*.conf
> >
> > Is there anything in there that shouldn't be or anything that should?
> >
> > This file has gone through several eprints upgrades so it's possible 
> that
>
> > it's wrong in places
> >
> > Lee
> >
> > Lee Paton
> > Information Services
> > Cardiff University
> > 40-42 Park Place
> > Cardiff
> > CF10 3BB
> >
> >
> >
> > From:   Tim Brody <tdb2 at ecs.soton.ac.uk>
> > To:     eprints-tech at ecs.soton.ac.uk
> > Date:   08/03/2012 14:49
> > Subject:        [EP-tech] Re: Uploading a file issue
> > Sent by:        eprints-tech-bounces at ecs.soton.ac.uk
> >
> >
> >
> > Are you using HTTPS?
> >
> > /Tim.
> >
> > On Thu, 2012-03-08 at 14:26 +0000, Lee Paton wrote:
> >> HI
> >>
> >> It depends on the browser I use.
> >>
> >> Chrome:        Error updating progress bar: TypeError: Cannot call
> >> method 'stop' of undefined
> >> Safari:                Error updating progress bar: TypeError:
> >> 'undefined' is not an object
> >> IE:                Error updating progress bar: TypeError: Access is
> >> denied
> >> Firefox:                Error updating progress bar: TypeError: pe id
> >> undefined
> >>
> >> My access log shows that I get a 302
> >> when /cgi/users/ajax/upload_progress is called
> >>
> >> Lee
> >>
> >> Lee Paton
> >> Information Services
> >> Cardiff University
> >> 40-42 Park Place
> >> Cardiff
> >> CF10 3BB
> >>
> >>
> >>
> >> From:        "Dimitrakakis Georgios" <giorgis at lib.uoc.gr>
> >> To:        eprints-tech at ecs.soton.ac.uk
> >> Date:        08/03/2012 14:07
> >> Subject:        [EP-tech] Re: Uploading a file issue
> >> Sent by:        eprints-tech-bounces at ecs.soton.ac.uk
> >>
> >> ______________________________________________________________________
> >>
> >>
> >>
> >> Lee,
> >>
> >> are you sure that it's the same error as mine?
> >>
> >> I mean do you see the message: "Error updating progress bar:
> >> TypeError:pe is undefined" when you try to upload a file???
> >>
> >> Is there any useful on the server error log?
> >>
> >> Best,
> >>
> >> G.
> >>
> >>
> >> > Thanks both
> >> >
> >> > I've regenerated the apache config (no changes) but the problem
> >> still
> >> > persists
> >> >
> >> > Lee
> >> >
> >> >
> >> > Lee Paton
> >> > Information Services
> >> > Cardiff University
> >> > 40-42 Park Place
> >> > Cardiff
> >> > CF10 3BB
> >> >
> >> >
> >> >
> >> > From:   "Dimitrakakis Georgios" <giorgis at lib.uoc.gr>
> >> > To:     eprints-tech at ecs.soton.ac.uk
> >> > Date:   08/03/2012 13:06
> >> > Subject:        [EP-tech] Re: Uploading a file issue
> >> > Sent by:        eprints-tech-bounces at ecs.soton.ac.uk
> >> >
> >> >
> >> >
> >> > Suggested by Tim Brody:
> >> >
> >> > #######
> >> > If you can, could you backup your apache conf and regenerate a blank
> >> > EPrints one?
> >> >
> >> > mv cfg/apache/foo.conf cfg/apache/foo.conf.bk
> >> > ./bin/generate_apacheconf
> >> > #######
> >> >
> >> > Best,
> >> >
> >> >
> >> > G.
> >> >
> >> >
> >> >> Hi
> >> >>
> >> >> I added the <Directory> directive and still get the message
> >> appearing.
> >> >>
> >> >> My cfg/apache/REPO.conf is at http://pastebin.com/bpB684MY
> >> >>
> >> >> The version of apache I'm using is 2.2.15-15
> >> >>
> >> >> Lee
> >> >>
> >> >>
> >> >>
> >> >>
> >> >> Lee Paton
> >> >> Information Services
> >> >> Cardiff University
> >> >> 40-42 Park Place
> >> >> Cardiff
> >> >> CF10 3BB
> >> >>
> >> >>
> >> >>
> >> >> From:   Tim Brody <tdb2 at ecs.soton.ac.uk>
> >> >> To:     eprints-tech at ecs.soton.ac.uk
> >> >> Date:   08/03/2012 11:52
> >> >> Subject:        [EP-tech] Re: Uploading a file issue
> >> >> Sent by:        eprints-tech-bounces at ecs.soton.ac.uk
> >> >>
> >> >>
> >> >>
> >> >> Hi,
> >> >>
> >> >> Sorry if I missed this before. Can you pastebin your entire
> >> >> cfg/apache/REPOSITORY.conf?
> >> >>
> >> >> And what version of Apache are you using?
> >> >>
> >> >> The default config has this:
> >> >> <Location "">
> >> >>     PerlSetVar EPrints_ArchiveID devel
> >> >>
> >> >>     Options +ExecCGI
> >> >>     Order allow,deny
> >> >>     Allow from all
> >> >> </Location>
> >> >>
> >> >> Which ought to set everything under EPrints as executable (e.g.
> >> static
> >> >> files go through the templating), so I'm wondering why this isn't
> >> being
> >> >> applied to /cgi.
> >> >>
> >> >> Thanks,
> >> >> Tim.
> >> >>
> >> >> On Thu, 2012-03-08 at 13:31 +0200, Dimitrakakis Georgios wrote:
> >> >>> Hi Lee and Tim!
> >> >>>
> >> >>> Sorry for not replying earlier but I 've been very busy!
> >> >>>
> >> >>> Tim,
> >> >>>
> >> >>> as I have written before the problem appears on specific browsers!
> >> >>> But even with those that they work I wasn't able to see the status
> >> bar
> >> >>> when I was uploading a really huge file.
> >> >>>
> >> >>> Anyway, what I added at
> >> the /opt/eprints/cfg/apache/REPOSITORY.conf
> >> >>> file was the following:
> >> >>>
> >> >>> <Directory /opt/eprints3/cgi/>
> >> >>>       AllowOverride None
> >> >>>       Options ExecCGI
> >> >>>       Order allow,deny
> >> >>>       Allow from all
> >> >>> </Directory>
> >> >>>
> >> >>> Restarted Apache and that was it!
> >> >>>
> >> >>> Lee, the above should solve your problem.
> >> >>>
> >> >>> Let us know!
> >> >>>
> >> >>> Once again sorry for not replying earlier because I know what it
> >> is to
> >> >>> be stuck and not receiving any hints/support.
> >> >>>
> >> >>> Best,
> >> >>>
> >> >>>
> >> >>> G.
> >> >>>
> >> >>> > Hi
> >> >>> >
> >> >>> > I have Options +ExecCGI in both the generated apache conf files:
> >> >>> >
> >> >>> > /usr/share/eprints/cfg/apache/orca.conf
> >> >>> > /usr/share/eprints/cfg/apache_ssl/orca.conf
> >> >>> >
> >> >>> > as well as Options ExecCGI FollowSymLinks in the
> >> >>> >
> >> >>> > /usr/share/eprints/secure.conf
> >> >>> >
> >> >>> > Is there anything else to look for?
> >> >>> >
> >> >>> > Lee
> >> >>> >
> >> >>> > Lee Paton
> >> >>> > Information Services
> >> >>> > Cardiff University
> >> >>> > 40-42 Park Place
> >> >>> > Cardiff
> >> >>> > CF10 3BB
> >> >>> >
> >> >>> >
> >> >>> >
> >> >>> > From:   "Dimitrakakis Georgios" <giorgis at lib.uoc.gr>
> >> >>> > To:     eprints-tech at ecs.soton.ac.uk
> >> >>> > Date:   07/03/2012 15:01
> >> >>> > Subject:        [EP-tech] Re: Uploading a file issue
> >> >>> > Sent by:        eprints-tech-bounces at ecs.soton.ac.uk
> >> >>> >
> >> >>> >
> >> >>> >
> >> >>> > Hi Lee!
> >> >>> >
> >> >>> > I was looking into this for many days.
> >> >>> >
> >> >>> > Make sure that the conf file has ExecCGI
> >> >>> >
> >> >>> > Best,
> >> >>> >
> >> >>> > G.
> >> >>> >
> >> >>> >
> >> >>> >> Hi
> >> >>> >>
> >> >>> >> Has anyone managed to find a work around?
> >> >>> >>
> >> >>> >> I've upgraded from 3.2.1 to 3.3.7 and this issue has just been
> >> >> brought
> >> >>> > to
> >> >>> >> my attention?
> >> >>> >>
> >> >>> >> Thanks
> >> >>> >>
> >> >>> >> Lee
> >> >>> >>
> >> >>> >> Lee Paton
> >> >>> >> Information Services
> >> >>> >> Cardiff University
> >> >>> >> 40-42 Park Place
> >> >>> >> Cardiff
> >> >>> >> CF10 3BB
> >> >>> >>
> >> >>> >>
> >> >>> >>
> >> >>> >> From:   "Dimitrakakis Georgios" <giorgis at lib.uoc.gr>
> >> >>> >> To:     eprints-tech at ecs.soton.ac.uk
> >> >>> >> Date:   18/01/2012 12:17
> >> >>> >> Subject:        [EP-tech] Re: Uploading a file issue
> >> >>> >> Sent by:        eprints-tech-bounces at ecs.soton.ac.uk
> >> >>> >>
> >> >>> >>
> >> >>> >>
> >> >>> >> I managed to narrow it down a bit!
> >> >>> >>
> >> >>> >> The AJAX progress bar is producing this error
> >> >>> >>
> >> >>> >> "Error updating progress bar: TypeError:pe is undefined"
> >> >>> >>
> >> >>> >> when using Firefox!
> >> >>> >>
> >> >>> >> If I  use Chrome the error is:
> >> >>> >>
> >> >>> >> "Error updating progress bar: TypeError: Cannot call method
> >> 'stop'
> >> > of
> >> >>> >> undefined"
> >> >>> >>
> >> >>> >>
> >> >>> >> On the other hand Opera, IE and Safari seem to work flawlessly.
> >> >>> >>
> >> >>> >>
> >> >>> >> Can someone verify the above? If not can you tell me which
> >> version
> >> > of
> >> >>> >> Firefox are you using?
> >> >>> >>
> >> >>> >> Best,
> >> >>> >>
> >> >>> >> G.
> >> >>> >>
> >> >>> >>
> >> >>> >>> Hello!
> >> >>> >>>
> >> >>> >>> Sorry for coming over and over again with this issue but I am
> >> >>> >>> desperate! So, can somebody point me to the the AJAX progress
> >> bar
> >> >> file
> >> >>> >>> to see what's going wrong.....
> >> >>> >>>
> >> >>> >>>
> >> >>> >>> Best,
> >> >>> >>>
> >> >>> >>> G.
> >> >>> >>>
> >> >>> >>>
> >> >>> >>>> Hi Tim!
> >> >>> >>>>
> >> >>> >>>> It's version v.3.3.7!
> >> >>> >>>>
> >> >>> >>>> Do I need to have something installed to the system for the
> >> AJAX
> >> >>> >>>> upload progress bar to work properly?
> >> >>> >>>>
> >> >>> >>>> Best,
> >> >>> >>>>
> >> >>> >>>> G.
> >> >>> >>>>
> >> >>> >>>>
> >> >>> >>>>> Hi,
> >> >>> >>>>>
> >> >>> >>>>> That looks like an error with the AJAX upload progress bar.
> >> >>> >>>>>
> >> >>> >>>>> What version of EPrints?
> >> >>> >>>>>
> >> >>> >>>>> /Tim.
> >> >>> >>>>>
> >> >>> >>>>> On Wed, 2012-01-11 at 17:35 +0200, Dimitrakakis Georgios
> >> wrote:
> >> >>> >>>>>> Hi people!
> >> >>> >>>>>>
> >> >>> >>>>>> First of all, let me give my Best Wishes for a Happy and
> >> >> prosperous
> >> >>> >>>>>> New Year to all of you!
> >> >>> >>>>>>
> >> >>> >>>>>> I am still trying to find a way to upload a file without
> >> > success!
> >> >>> >>>>>> Does anyone of you have the sliest idea of what might be
> >> the
> >> >> issue?
> >> >>> >>>>>>
> >> >>> >>>>>> Best,
> >> >>> >>>>>>
> >> >>> >>>>>> G.
> >> >>> >>>>>>
> >> >>> >>>>>> > Following a previously submitted post (but without
> >> solution or
> >> >> at
> >> >>> >>>>>> > least I couldn't find it in the archives), could you
> >> please
> >> >> help
> >> >>> > me
> >> >>> >>>>>> > and tell me how to solve the following error when trying
> >> to
> >> >> update
> >> >>> >> a
> >> >>> >>>>>> > file??
> >> >>> >>>>>> >
> >> >>> >>>>>> > "Error updating progress bar: TypeError:pe is undefined"
> >> >>> >>>>>> >
> >> >>> >>>>>> >
> >> >>> >>>>>> > Best,
> >> >>> >>>>>> >
> >> >>> >>>>>> > G.
> >> >>> >>>>>> >
> >> >>> >>>>>> >
> >> >> ----------------------------------------------------------------
> >> >>> >>>>>> > This message was sent using IMP, the Internet Messaging
> >> >> Program.
> >> >>> >>>>>> >
> >> >>> >>>>>> > *** Options:
> >> >>> >>>>>>
> >> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> >>> >>>>>> > *** Archive: http://www.eprints.org/tech.php/
> >> >>> >>>>>> > *** EPrints community wiki:http://wiki.eprints.org/
> >> >>> >>>>>> >
> >> >>> >>>>>>
> >> >>> >>>>>>
> >> ----------------------------------------------------------------
> >> >>> >>>>>> This message was sent using IMP, the Internet Messaging
> >> Program.
> >> >>> >>>>>>
> >> >>> >>>>>> *** Options:
> >> >>> >> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> >>> >>>>>> *** Archive: http://www.eprints.org/tech.php/
> >> >>> >>>>>> *** EPrints community wiki: http://wiki.eprints.org/
> >> >>> >>>>>
> >> >>> >>>>>
> >> >>> >>>>> *** Options:
> >> >>> >> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> >>> >>>>> *** Archive: http://www.eprints.org/tech.php/
> >> >>> >>>>> *** EPrints community wiki: http://wiki.eprints.org/
> >> >>> >>>>
> >> >>> >>>>
> >> >>> >>>>
> >> ----------------------------------------------------------------
> >> >>> >>>> This message was sent using IMP, the Internet Messaging
> >> Program.
> >> >>> >>>>
> >> >>> >>>> *** Options:
> >> >>> >> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> >>> >>>> *** Archive: http://www.eprints.org/tech.php/
> >> >>> >>>> *** EPrints community wiki: http://wiki.eprints.org/
> >> >>> >>>>
> >> >>> >>>
> >> >>> >>>
> >> ----------------------------------------------------------------
> >> >>> >>> This message was sent using IMP, the Internet Messaging
> >> Program.
> >> >>> >>>
> >> >>> >>> *** Options:
> >> >>> >> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> >>> >>> *** Archive: http://www.eprints.org/tech.php/
> >> >>> >>> *** EPrints community wiki: http://wiki.eprints.org/
> >> >>> >>>
> >> >>> >>
> >> >>> >>
> >> ----------------------------------------------------------------
> >> >>> >> This message was sent using IMP, the Internet Messaging
> >> Program.
> >> >>> >>
> >> >>> >> *** Options:
> >> >>> > http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> >>> >> *** Archive: http://www.eprints.org/tech.php/
> >> >>> >> *** EPrints community wiki: http://wiki.eprints.org/
> >> >>> >>
> >> >>> >>
> >> >>> >
> >> >>> > ----------------------------------------------------------------
> >> >>> > This message was sent using IMP, the Internet Messaging Program.
> >> >>> >
> >> >>> > *** Options:
> >> >> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> >>> > *** Archive: http://www.eprints.org/tech.php/
> >> >>> > *** EPrints community wiki: http://wiki.eprints.org/
> >> >>> >
> >> >>> >
> >> >>>
> >> >>> ----------------------------------------------------------------
> >> >>> This message was sent using IMP, the Internet Messaging Program.
> >> >>>
> >> >>> *** Options:
> >> >> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> >>> *** Archive: http://www.eprints.org/tech.php/
> >> >>> *** EPrints community wiki: http://wiki.eprints.org/
> >> >>
> >> >>
> >> >> *** Options:
> >> > http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> >> *** Archive: http://www.eprints.org/tech.php/
> >> >> *** EPrints community wiki: http://wiki.eprints.org/
> >> >>
> >> >>
> >> >
> >> > ----------------------------------------------------------------
> >> > This message was sent using IMP, the Internet Messaging Program.
> >> >
> >> > *** Options:
> >> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> > *** Archive: http://www.eprints.org/tech.php/
> >> > *** EPrints community wiki: http://wiki.eprints.org/
> >> >
> >>
> >> ----------------------------------------------------------------
> >> This message was sent using IMP, the Internet Messaging Program.
> >>
> >> *** Options:
> >> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> *** Archive: http://www.eprints.org/tech.php/
> >> *** EPrints community wiki: http://wiki.eprints.org/
> >>
> >> *** Options:
> > http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> >> *** Archive: http://www.eprints.org/tech.php/
> >> *** EPrints community wiki: http://wiki.eprints.org/
> >
> >
> > *** Options: 
> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> > *** Archive: http://www.eprints.org/tech.php/
> > *** EPrints community wiki: http://wiki.eprints.org/
>
> -- 
> All the best,
> Tim.
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
>
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20120309/765d0957/attachment-0001.html 


More information about the Eprints-tech mailing list