[EP-tech] Re: REF2014 Plug-in installation failed because of duplicate fields

Tian, Jia J.Tian at kingston.ac.uk
Thu Mar 8 12:38:42 GMT 2012


Dear Seb,

Thanks a lot for the update. I will wait for the new version and give another try.

Best Wishes,
Jia


Jia Tian
Systems Analyst, Infrastructure, Information Services

T   Internal: 62079
T   020 8417 2079

Kingston University London
Penrhyn Road, Kingston upon Thames KT1 2EE
www.kingston.ac.uk<http://www.kingston.ac.uk>

Information in this email and any attachments are confi dential, and may not be copied or used by anyone other than the addressee, nor disclosed
to any third party without our permission. There is no intention to create any legally binding contract or other commitment through the use of this email.
Please consider the environment before printing this email.

From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Sebastien Francois
Sent: 08 March 2012 12:21
To: eprints-tech at ecs.soton.ac.uk
Subject: [EP-tech] Re: REF2014 Plug-in installation failed because of duplicate fields

Jia,

Good news about the update!

These 2 user workflows should definitely appear when viewing a user profile so I guess there is a problem. I will try to fix this today & upload another update. I'll be in touch on this mailing list.

Kind regards,
Seb.

On 07/03/12 12:18, Tian, Jia wrote:
Dear Seb,

Thank you very much for the kind fixes!

I have tested the new REF2014 Bazaar package 1.0.1 and it works for our R4R-featured repository. I didn't see any error when I installed the Bazaar package. Also I did a manual run "epadmin upgrade <archiveid>" and no errors popped up which double confirmed the database schema upgrading succeeded.

But there was an issue that I need to manually copy the content of the following two files into the file "/opt/eprints3/archives/<archive_id>/cfg/workflows/user/default.xml".


/opt/eprints3/lib/workflows/user ref.xml

/opt/eprints3/lib/workflows/user uoa_champion.xml


Otherwise, I cannot see the REF section and UoA Champion section displaying in the User Profile. I am not sure whether it's Bazaar related or 3.3.8 version related. Additionally our EPrints version was 3.2.6 before and it got upgraded to 3.3.7 last December and then further to the current version 3.3.8 this January. This is not a critical problem, but it did took me a while to notice.

Another small bug is that one phrase is missing in the file "/opt/eprints3/lib/lang/en/phrases/ref.xml", therefore I added the following line into that file.
            <epp:phrase id="user:workflow:stage:ref:title">UoA Champion</epp:phrase>

I followed the User Guide Manual on EPrints website to perform several simple tests on the REF2014 plug-in and it seems working perfectly. Thanks again for the great help!

Best Wishes,
Jia



This email has been scanned for all viruses by the MessageLabs Email
Security System.

This email has been scanned for all viruses by the MessageLabs Email
Security System.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20120308/61c94d74/attachment.html 


More information about the Eprints-tech mailing list