[EP-tech] Re: Importing files from another system

Sebastien Francois sf2 at ecs.soton.ac.uk
Thu Jun 21 15:08:06 BST 2012


Hi John,

See an example attached - tested on 3.3.9, imported this way:

bin/import <REPO_ID> --enable-file-imports --enable-web-imports --user 1 
--verbose eprint XML ./export2.xml

Seb.

PS: in the attached XML, I replaced the URL of my dev machine with 
__REPO_URL__, change this to your repository URL.

On 21/06/12 14:55, John Salter wrote:
> Yep - that didn't work either :o\
>
> According to this:
> http://wiki.eprints.org/w/Import_From_URL
> I was also missing a<files>  around the<file>.
> I've added that and re-tried all the options, so far none work :o\
>
> Any other suggestions?
>
> Cheers,
> John
>
> -----Original Message-----
> From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Jose Martin
> Sent: 21 June 2012 14:40
> To: eprints-tech at ecs.soton.ac.uk
> Subject: [EP-tech] Re: Importing files from another system
>
> Have you tried for local files
>
> 	<url>file:///path_to_file</url>
>
> ?
>
> -----Original Message-----
> From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of John Salter
> Sent: 21 June 2012 14:24
> To: 'eprints-tech at ecs.soton.ac.uk'
> Subject: [EP-tech] Re: Importing files from another system
>
> Nothing silly in the verbose output.
>
> I can wget the file over http (when trying the http method), but even using the file from the local filesystem doesn't work :o\
>
>
> -----Original Message-----
> From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of Yuri
> Sent: 21 June 2012 13:48
> To: eprints-tech at ecs.soton.ac.uk
> Subject: [EP-tech] Re: Importing files from another system
>
> run the command with --verbose --verbose and try to see what happen. Can you go to port 80 from the server to another server? Check your firewall settings.
>
> Il 21/06/2012 14:22, John Salter ha scritto:
>> Hi,
>> I'm trying to import files from another system, into EPrints.
>> I can either copy the files onto the server, or make them available over http.
>>
>> In the XML, I've tried specifying (in an<eprints><eprint>   node)
>> <document>
>> 	<file href="/path/to/my.pdf" />
>> </document>
>>    - or -
>> <document>
>> 	<file>
>> 		<url>http://url.of/my.pdf</url>
>> 	</file>
>> </document>
>>
>> And importing with:
>>> bin/import ARCHIVENAME --enable-file-imports --enable-web-imports
>>> --user 1 archive XML test.xml
>> Both import the metadata from the XML OK, but neither option attaches the file to the eprint.
>>
>> What am I doing wrong - or will this even work?
>>
>> Cheers,
>> John
>> *** Options:
>> http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
>> *** Archive: http://www.eprints.org/tech.php/
>> *** EPrints community wiki: http://wiki.eprints.org/
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/
>
> *** Options: http://mailman.ecs.soton.ac.uk/mailman/listinfo/eprints-tech
> *** Archive: http://www.eprints.org/tech.php/
> *** EPrints community wiki: http://wiki.eprints.org/

-------------- next part --------------
A non-text attachment was scrubbed...
Name: export2.xml
Type: text/xml
Size: 1663 bytes
Desc: not available
Url : http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20120621/a17e8cdd/attachment-0001.xml 


More information about the Eprints-tech mailing list