[EP-tech] Upgrading REF2014 plugin issues

Lee Paton PatonL at cardiff.ac.uk
Fri Jun 15 14:29:03 BST 2012


Hi

I'm running eprints 3.3.7 and are trying to upgrade the REF2014 plugin 
from version 1.0.5 to 1.1.1 but seem to be hitting a problem

When upgrading from the Bazaar I get the following message:

Checksum mismatch encountered for lang/en/phrases/ref.xml

I did change a phrase in this file but have since reverted to the default 
version from the plugin. If I then reload the eprints config I get an 
apache 500 error and the following error appears in the log file:

[Fri Jun 15 13:59:43 2012] [error] [client 10.224.4.168] Can't locate 
object method "default" via package "EPrints::DataObj::REFBenchmark" at 
/usr/share/eprints/lib/plugins/EPrints/Plugin/Screen/REF.pm line 146.\n

I've had a look at the eprints directory structure and it appears some 
parts of the upgrade have taken place as the following files are gone from 
below /usr/share/eprints/archives/<repo>/cfg:

!       cfg.d/zz_ref_reports.pl
!       cfg.d/zz_ref_benchmark.pl
!       epm/ref2014
!       subjects_uoa

The files below /usr/share/eprints/lib and /usr/share/eprints/perl_lib 
appear to be untouched

Has anyone have any advice?

Thanks

Lee

Lee Paton 
Information Services
Cardiff University
40-42 Park Place
Cardiff
CF10 3BB
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20120615/0c1cbdca/attachment.html 


More information about the Eprints-tech mailing list