[EP-tech] Re: Abstract shows html tags

John Salter J.Salter at leeds.ac.uk
Fri Dec 21 10:54:44 GMT 2012


Hi,
For (1), rendering a field that may contain HTML, you probably want to define a 'render_value' for the field in ~/archives/[ARCHIVEID]/cfg/cfg.d/eprint_fields.pl.
The 'suggestions' field has an example. It uses a function defined in ~/perl_lib/EPrints/Extras.pm.
You could try updating the 'abstract' definition to:
{
  'name' => 'abstract',
  'type' => 'longtext',
  'input_rows' => 10,
  'render_value' => 'EPrints::Extras::render_xhtml_field',
},

You can test the change by and regenerate an abstract by running ~/bin/generate_abstracts ARCHIVEID eprintid
 - and remember to restart Apache after making the edits to files in cfg/cfg.d.

For (2), look in ~/archives/[ARCHIVEID]/cfg/cfg.d/eprint_render.pl
You can comment out lines for the fields you don't need (you may also want to remove the references to the fields in the workflow - so people aren't entering data when it's not going to be shown).

Cheers,
John

-----Original Message-----
From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of sumesh at ias.ernet.in
Sent: 21 December 2012 06:59
To: eprints-tech at ecs.soton.ac.uk
Subject: [EP-tech] Abstract shows html tags

Deal All,

    Installation of eprints(3.1.3) in new server has some problems.

1. Abstract section is showing the html tags , which is not supposed to do
so.

2. I need to avoid display  of 3 fields from the page.

A screenshot is attached herewith for clarity.

 Anyone please provide the necessary changes to be made to solve these.



-- 
Regards

Sumesh.KS



More information about the Eprints-tech mailing list