[EP-tech] Re: Failed to load EPrints::Apache::Rewrite package

Mark Gregson mark.gregson at qut.edu.au
Wed Dec 5 23:32:13 GMT 2012


The Perl @INC in the error message doesn't include EPrints Perl library, /opt/eprints3/perl_lib (or whatever your install path is) - I suspect this is a problem with the Apache config.

There should be a "PerlSwitches -I/usr/local/eprints/perl_lib" line in /opt/eprints3/cfg/apache.conf, which must be included in your top-level Apache config so that it is in effect for both http and https virtual hosts; I suspect this line is missing.  Perhaps the eprints apache conf is not being included correctly.

Cheers
Mark

From: eprints-tech-bounces at ecs.soton.ac.uk [mailto:eprints-tech-bounces at ecs.soton.ac.uk] On Behalf Of David Kane
Sent: Thursday, 6 December 2012 3:45 AM
To: EPrints.org Technical List
Subject: [EP-tech] Failed to load EPrints::Apache::Rewrite package

Hi,

I have upgraded from 3.3.6 to 3.3.10 and when I restart apache, I get the following in the apache error log:

[Wed Dec 05 16:04:51 2012] [error] Can't locate EPrints/Apache/Rewrite.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl . /etc/apache2) at (eval 2) line 3.\n
failed to load EPrints::Apache::Rewrite package

I downgraded sharpish.  However I still get the same darn error message.

I solved it by removing https://  but I want my https://

Any ideas as to how I can solve this?

Thanks,

David.

--
David Kane, MLIS.
Systems Librarian
Waterford Institute of Technology
Ireland
http://library.wit.ie/
T: ++353.51302838
M: ++353.876693212
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ecs.soton.ac.uk/pipermail/eprints-tech/attachments/20121206/33cf7358/attachment-0001.html 


More information about the Eprints-tech mailing list